Bioshock Infinite – From choppy to perfectly smooth on ultra

Home Forums Game Hints and Settings Bioshock Infinite – From choppy to perfectly smooth on ultra

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #193418
    moarveer
    Participant

    So I’ve battled for a long time to get Bioshock Infinite playable on the Pimax 8k, but never got good enough results. Today I gave it another try, but even on z3d it was choppy, which is ridiculous since a taxing game like Kingdom Come Deliverance is very playable on z3d with the Pimax 8K, so something is amiss.

    Well after trying this https://steamcommunity.com/sharedfiles/filedetails/?id=161397496 the game went from choppy even on z3d to fully playable at 3k resolution and geometry 3d on ultra:

    INI Modifications
    Navigate to %USERPROFILE%\My Documents\My Games\BioShock Infinite\XGame\Config
    Use your favorite text editor to open Xengine.ini
    Modify the values of the following parameters to the values shown below. PoolSize should be set according to the amount of VRAM you have.

    UseTextureFileCache=False
    PoolSize=3000
    TexturePoolSizeReductionMB=1500
    LowPCTexturePoolSizeMB=3000
    OneFrameThreadLag=False
    bSmoothFrameRate=False

    Launch Options
    Add the following parameter to the Bioshock Infinite launch options.
    -ReadTexturePoolFromIni

    Actually I forgot to add the Launch Options line mentioned there, but the game is now fully playable at max settings and geo3d.

    Note to Pimax users: in this game in particular you can boost the gpu scaling to max using pitool 258

    #193420
    steph12
    Participant

    thanks man for sharing this :D

    i have a gtx 1080 with 8192mb of vram so how do i set this ?

    PoolSize=3000
    TexturePoolSizeReductionMB=1500
    LowPCTexturePoolSizeMB=3000

    #193421
    moarveer
    Participant

    I have a 1080ti with 12gb so I used:

    PoolSize=12000
    TexturePoolSizeReductionMB=1500
    LowPCTexturePoolSizeMB=3000

    I even tried incresing the resolution a bit more to 3413×1920 DSR resolution, it looks incredibly sharp and full speed at ultra and geometry 3d.

    #193423
    steph12
    Participant

    alright, thanks again :)

    i hope it’ll work for me as well ^^

    #193432
    moarveer
    Participant

    I hope it works for you. One more tip, if you hit left alt you will start slow walking, which feels way more natural in VR that the normal walk speed.

    #193442
    steph12
    Participant

    i play with htc vive wands ^^

    #193447
    moarveer
    Participant

    I’ve never used Vive wands as controllers, how do you set all the keys to work, there’re not that many buttons on the wand.

    #193448
    steph12
    Participant

    you can rebind keys as you know, with grip buttons on the controlers you can have 2 set of commands per wand, enough to have a decent gameplay, you cant bind everything but you can bind just enough commands to play without using keyboard/mouse/gamepad.

    #193457
    moarveer
    Participant

    I’ll investigate this at some point, but with BI I think it’d be impossible, there are buttons for weapons, powers, and the usual controls for movement, sprint, etc. That’s just too much imho.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.