FiveM

This topic contains 10 replies, has 3 voices, and was last updated by  CrypticDolphin1 1 month, 2 weeks ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #180265

    Hello everyone! Recently bought VorpX to see if I could get it to work in a Grand Theft Auto 5 modification called FiveM. FiveM is essentially a framework for custom multiplayer servers. So far I have had success in getting this game to somewhat work in VR. I hooked the standard GTA 5 profile to FiveM_GTAProcess and full 360 degree head rotation is working. However, the resolution is very poor. It is like looking at a blurry square that does not cover my full vision. Any help on getting this game to work would be very much appreciated, it should be very similar to regular GTA!

    #180266

    Ralf
    Keymaster

    You can change the game’s resolution on the DirectVR page of the vorpX ingame menu. The option is named ‘Preferred Resolution Quality’.

    If that doesn’t work, you can disable automatic resolution there and set a 4:3 res manually, e.g. 1600×1200 or 1920×1440.

    If these resolutions aren’t available on your PC, check the custom resolutions post.

    #180268

    It seems to be treating the entire game as a HUD.

    #180269

    Ralf
    Keymaster

    Not sure if I understand the issue, but please reset the profile to default (config app/trouble shooting page) and try without the mod.

    Let me know if the issue also applies with default settings and an unmodded game. Officially supporting mods is not really feasible unfortunately.

    #180270

    FiveM is a separate application that grabs files from grand theft auto. I am sure that this software works fine with grand theft auto story mode, but I was hoping to use it with FiveM. You can learn more here https://fivem.net/

    #180274

    Good news, I have been able to get VorpX working in FiveM with minor problems. I will post a guide once everything is perfected, but for now I am simply trying to get the game to display to my Vr headsets native resolution (1600×1440). I was able to do this for GTA story mode using steams launch options, but FiveM dosen’t seem to recognize that as it does not launch through steam. I also tried using the commandline.txt file to set a custom res there, but still no dice. If anyone has any insights into fixing this problem let me know, I will continue searching myself. I am so close!

    #180322

    I have tried setting the resolution for GTA 5 through a commandline.txt file in the GTA 5 directory, steam launch options and the settings.xml file. None of these settings are applying when I launch the game. I checked ‘Dont optimize game settings’ in VorpX, does that stop VorpX from adjusting the resolution?

    #180326

    dellrifter22
    Member

    Some games allow custom aspect ratios and resolutions that you can switch too while in game. Generally you need to first create these resolutions in Nvidia control panel beforehand (see thread for details), and they should show up in your game settings to choose from. I’ve made a list of 20+ custom resolutions in my control panel that now show up in games as selectable, making it easy to see which looks best.

    You could try making one for 1440×1600 (I believe you meant, for vivepro or odyssey), and see if it shows up in GTA5 video settings while playing.

    Note however that this aspect ratio will likely not work well for most games, and you will likely end up using the recommended 4:3, 16:10 options.

    Instead of checking “Don’t optimize” (leave that on to handle other settings), you want to disable specifically the Preferred Resolution setting only of the DirectVR page of the Delete Key menu in game.

    #180781

    I am back! Had to take a little break from trying to get this to work, but I am back at it.

    The reason for checking “don’t optimize” is because if I don’t, cars look like this when I get in them. Otherwise everything is fine. Not sure what the issue is here.

    VorpX FiveM broken vehicles

    #180782

    The image plug did not seem to work, here is a direct link. https://imgur.com/a/yNVXhVs

    #180785

    It is resolution related. The game was set to my monitors resolution of 2560×1080. What resolution/ aspect ratio would you recon for a Samsung odyssey plus?

    I tried setting the games resolution to the odysseys native resolution and a aspect ratio of 16:10 but the game defaulted back to 800×600. I dont see this “preferred resolution” option anywhere in the delete menu.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.