Last vorpx much better performance in rocket league

Homepage Forums General vorpX Discussion Last vorpx much better performance in rocket league

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #177513

    I just tried the newest vorpx updates and it’s completely killed the reprojection (steamvr or vorpx fluid sync, not sure what it was using before)

    It used to be that I would join a match and the game would be choppy for about 5 seconds but then everything would iron out and be buttery smooth thanks to the fluid sync. Since the new update it’s just choppy all the time now!

    I tried the vorpx advanced settings and turning the direct mode fluid sync on and off has no effect.

    I feel this update has made things much worse than just leaving it how it was with the SteamVR motion smoothing. Keep in mind all of my SteamVR supersampling settings are set to default. It’s like the fluid sync is completely broken now.

    I would recommend the dev download rocket league and try the previous version from 2 weeks ago and then compare smoothness to lack of reprojection on this version.


    No measurable difference here in a brief test. 1080Ti, 1920×1200, high details.
    45/90 with FluidSync, 62/90 without. Since the game’s frame rate is capped at 62fps exactly what one would expect. Without the cap (which is not vorpX related) it would probably run at 90/90.

    I’ll do some more in-depth tests next week, but judging from the brief check nothing seems to have changed for Rocket League.


    You can change the max fps to 250 in the game options under video.

    I just tested further. I reverted back to 18.3.1 to test (unplugged the internet so it wouldn’t update) I had made a backup of the folder and just pasted over the old version (ended vorpx driver task)

    Here is what I have game fps 80 direct mode fps 60 and it’s reprojecting running very smooth on old vorpx 18.3.1.

    Then plugged in internet and did the vorpx update again: gets
    game fps 40 direct mode fps reports 60 but it’s very choppy and not doing the smoothing async render stuff. I tried turning supersampling down to 20% and it still gets bad frames.

    1080Ti here. Pimax 8k. I will test the rift and Vive next and odyssey+ next.


    No problem to get buttery smooth 90/90 on a Vive with high details at 1920×1200.

    As far as I’m aware the Pimax 8k has it’s own reprojection (‘Brainwarp’), it doesn’t use the SteamVR reprojection. If this ‘Brainwarp’ doesn’t kick in for some reason, you have to make sure that the game runs with xx/80 to work correctly with vorpX (IIRC the 8k’s native refresh rate is 80).


    Hmm, more info.. I was always able to run max graphics on odyssey+ at this res (but turn off motion blur on the odyssey+). I am having this issue with the Odyssey+ now! (reprojection doesn’t want to kick in)

    In the 18.3.1 previous version I get 90/90 and it’s very smooth and If it reprojects down to 45 still smooth.

    In the new vorpx version I get 45/90 and it’s very choppy and it’s not using the reprojection does not kick in like it used to :(

    PS I will try to turn the pitool down to 1.0 for the pimax and see what happens in the meantime.

    Also it’s weird because I have always been using 2560×1440 max setting and it’s been smooth on odyssey+, on the Vive I had to always turn it to” performance” in video setting for this res but I kept high quality rendering setting.


    As said above, I’ll do some more Rocket League tests including WMR next week. With a Vive everything looks perfectly normal and smooth as always. Would be quite a surprise to see WMR behave any different, but who knows. Everything is possible, of course. It’s Sunday evening here though, so sorry for being able to do more testing immediately.

    Just in case: double check whether SteamVR is up-to-date (should be 1.1.4).


    Thank you, no problem take your time. yes 1.1.4. last info: Odyssey+ is now better to some extent (test new version) by turning fluid sync off. Now it reports 90/90 again. but if it drops frames with a lot of cars it’s not reprojecting in new version and gets juddery.

    I think the issue could be that fluid sync is not kicking in new version even when you force it on for WMR, pimax. When the frames drop in the 18.3.1 version it’s still buttery smooth. I still have to test the Vive and rift.

    Edit: Also try out the cloud profile called [rocket league] by rocket league when you do test. It’s very nice!


    One more (last for today) test at 2560×1440 (Vive). Also buttery smooth 90/90 without any issues. Rocket League works perfectly fine.


    Okay I think I figured it out!

    in the new vorpx version with the fluid sync is set to auto on the Pimax and WMR everything is choppy. When I turn it off everything is smooth again! Maybe because it seems to kick back to their respective reprojection tech I think and framerate shoots up to 90 also. (80 on pimax 8k)

    Also the Pitool has to remain at 1.0 for pimax users.

    Is there a way to make the Rocket league profile default to “fluid sync off” by default if it detects WMR and pimax users?

    My rift is buried in closet but I imagine it might be a similar situation.

    Hope this helps.

    PS: Also The default vorpx rocket league profile is really good actually, I would just recommend when you get time bumping the 3D from 1.0 to 2.0 as it gives the cars and scene more realistic depth (and I have heard that is about their approx size of those cars if they existed IRL ;) After turning in game camera fov to 110.


    One more thing for when you check it out next week. There is a problem where you can’t text chat anymore with the T key.

    It’s weird because everything else works all other keys. I tried remapping it but doesn’t help. It’s like the chat box just doesn’t exist anymore. So weird.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!