RDR2 Trouble: Social Club Error 4

Homepage Forums Technical Support RDR2 Trouble: Social Club Error 4

Viewing 13 posts - 16 through 28 (of 28 total)
  • Author
    Posts
  • #201039
    LuigiChoolis
    Participant

    Oh, I forgot to mention this: as a possible valid reference, I run Half-Life: Alyx with this same setup without a glitch in high quality. I don’t know if that tells you anything but I figure I’d let you know since that game requires a pretty powerful VR setup to even run.

    Best, Hugo

    #201060
    Ralf
    Keymaster

    Just checked this for you with a Quest 1, but can’t replicate your problem here. Although with a faster GTX3080, which allows to run the game easily at the full 72FPS at 2560×1440. That’s a reasonable resolution for this game. Checked both SteamVR and native Oculus (the latter only works with the Rockstar Club version, not the Steam version).

    With your GPU under normal circumstances you should be able to reach smooth 45fps (half the headset refresh rate) at 2560×1440 without much of a problem. Please try the following things:

    1. Reset the vorpX profile to default in the config app.
    2. If you changed any Oculus Link settings (most importantly the encoding resolution), reset them to default.
    3. Start the game directly from the Windows Desktop, not using the vorpX desktop viewer. Shouldn’t really matter, but just in case.
    4. Enable FluidSync in the vorpX menu (caps frame rate at half the headset refresh rate)
    5. Set the game resolution to 2560×1440
    6. Start with the game’s graphics settings set to medium, raise/lower depending on whether you can reach stable 45fps or not
    7. If you use an FOV hack, try without. A higher FOV means more has to be rendered, which can have a fairly huge impact on performance.
    8. If you have any other mods installed, try without

    If the above doesn’t help, check for potential conflicts with other programs that also might hook into games. The pinned trouble shooting guide on top of this sub forum has more details on the matter.

    #201071
    LuigiChoolis
    Participant

    Thank you very much Ralf, I’m going to try all those things and come back to you later :D

    Best, Hugo

    #201081
    LuigiChoolis
    Participant

    Hi Ralph,

    so I did a lot of testing today, I have a lot of info.

    First, I managed to run RDR2 with Vorpx at 72 FPS game and 72 FPS at 2560×1440, but I had to bring the RDR2 Global Quality to 0.
    I also achieved a more constant and very fluid 72/72 at 2048×1536 with Global Quality at 5. That moment was definitely magic, had not achieved such fluidity with Vorpx before.

    To achieve this I had to turn off a number of things in Vorpx, but it wasn’t much of a bother. Turning off these settings was crucial though, improved FPS massively:

    DISPLAY SETTINGS
    Headset Sync: Safe
    Direct Mode Async Render: Off
    Tracking Prediction: Off

    IMAGE SETTINGS
    Crystal Image: Off (huge change)

    MAIN SETTINGS
    Head tracking multiplier: 0.00
    Headset Sync: Safe

    HEAD TRACKING SETTINGS
    Head Tracking: Off

    So now that I know what 72 FPS feels like in Vorpx + RDR2 I would like to stay at that level but try to improve the graphics side a tiny bit. I have a number of questions:

    . I notice that sometimes when you change settings in RDR2 and you go back to the game, the FPS goes drastically down, and you have to go back to settings and change maybe one notch in Global Quality and suddenly when you return to the game it’s 72/72 FPS again. Why would this happen? Once it’s at 72/72 it’s very estable, mind you.

    . I also notice that unusual factors have an influence in the FPS, such as:
    – Whether the external monitor display is connected to the computer or not (when I disconnected the external monitor the FPS suddenly went down to like 20-21 FPS, unplayable)
    – Whether you have been playing for a while (at one point I was running 2560×1440 with 72/72 FPS but later after I had been playing at a lower resolution for a while, I could not go back to it with good results)

    Why does this happen? is there such a thing as “the gpu needs time to estabilize after changing settings”?

    . I also noticed a very peculiar thing: OVRServer_x64.exe , the process that does everything for Oculus, takes a huge amount of GPU when it’s running. That’s understandable to a point, and obviously not Vorpx’s fault, but do you know any way to tame OVRServer_x64.exe so it can run properly but not hog the GPU?

    So that said, things are getting better and I hope you have some more feedback to try and squeeze some more graphic quality out of Vorpx + RDR2 :D

    Hope some of my findings help you out in some way :D Thanks for the help as always.

    Best, Hugo

    #201082
    LuigiChoolis
    Participant

    Oh by the way, I forgot to add this question, but it’s connected to my last question above:
    Since I now I’m not using head tracking in Vorpx (and that’s perfectly fine, I don’t miss it) could I turn off Guardian while playing Vorpx + RDR2 to perhaps get OVRServer_x64.exe to use a little bit less GPU and then turn up graphics in RDR2? Have you tried that before? I’m assuming OVRServer_x64.exe takes care of tracking and everything else in the Quest 2 while it’s running, so maybe I can free up some of the resources it’s using.

    Best, Hugo

    #201086
    Ralf
    Keymaster

    I can’t really suggest much more than what I suggested above. I think with your 5700XT the better goal to aim at is having a stable framerate of half the headset refresh rate by using FluidSync. If you want a completely stable full frame rate at high resolutions in RDR2, your GPU may be just little bit too slow. That’s a goal more suitable for a cutting edge high end GPU.

    One thing I noticed is that you changed the ‘Headset Sync’ to safe. That can be better latency wise, but on the other just as often causes a pretty noticable performance dip (up to 20%), so better leave it at fast if you aim for maximum performance. Also most of the time leaving ‘Async Rendering’ on will be the better choice. No harm in trying, but typically you don’t really want to touch these settings at all actually, in most cases the defaults are what works best for a given headset.

    Thanks for the Crystal Image hint. Might be a good idea to handle this a bit differently for Quest headsets with their additional video compression stage in the Oculus runtime.

    #201126
    LuigiChoolis
    Participant

    Thanks Ralf! I will try those settings you mention again and see what comes of it :D In the middle of so much testing sometimes you see what you want to see and not what is really there, so it’s more than possible that I thought those settings were doing the opposite of what really happened :D

    One thing I can say is that in my situation going for the estable half headset FPS was around 30-36 in reality, it’s quite choppy with my setup. So I would rather do whatever it takes to stay at a estable 72 FPS. I mean, even at a 1080 with a estable 72 FPS it looks kinda like the PSVR, so it’s not the worst thing in the world really, quite enjoyable. The choppiness just kills it for me.

    I came to the same conclusion as you yesterday, to get this thing really working the way I want it I’m going to have to get a top-of-the-line 16gb GPU. Unfortunately that’s going to be impossible at the moment since there’s no stock anywhere, so I will have to live with what I have now :D

    Thanks as always for the advice :D

    Best, Hugo

    #201127
    Ralf
    Keymaster

    The trick in case of lower framerates feeling choppy is to enable FluidSync. FluidSync caps the game framerate at exactly half the headset refresh rate. In your case that would be 36. Provided you can keep up these 36fps fully stable, sometimes that can feel smoother than a higher framerate fluctuating between for example 40 and 60.

    Also, just in case: use vorpX’s built in fps counter (ALT-F). I will show you two framerates. With FluidSync enabled it should ideally always show 36/72 in your case, 36 being the fps the game runs with and 72 the fps vorpX uses for sending the final image to the headset.

    #201128
    LuigiChoolis
    Participant

    Oh wait a seccond, you’re saying something there. Yes, I was using alt + F all the time, that’s how I know the frames on the different resolutions and settings.

    So the reason I tested but did not go with FluidSync is because it gave me 36/36, not 36/72 as you mentioned. It never gave me 36/72, not once. It might have given me 72/72, but never 36/72.

    In fact, the FPS was mostly either 72/72 when I ran at a graphics level that was affordable, very constant, or 30/30 (36/36) if I ran the graphics a bit hard. It was rarely fluctuating with other numbers, unless I went into Valentine or similar, at that point depending on the graphics it could go all the way from 72/72 to 36/36 suddenly.

    I’m going to test some more today and see :D

    #201129
    Ralf
    Keymaster

    Always stable 36/36 should also be OK. Not what I would like to see ideally since I’d always like vorpX to do the upscale from the game’s 36 to the headset’s 72, but if the Oculus runtime decides to throttle to 36 and you see stable 36/36 in the vorpX fps counter, the headset runtime will do it later. At least in theory that should also feel smooth. If not, try to reduce graphics details a bit more until there is enough headroom for 36/72.

    I’m afraid I’m out of useful tips now in that regard.

    #201149
    LuigiChoolis
    Participant

    Uhm, to be honest after testing some more the 36/36 just feels choppy in my setup, haven’t found any way to make it better. But like I mentioned before at 1920×1080 and half the quality it looks pretty good, kinda like a PSVR, so I’m happy enough to stay there until stock grows and I can get a better graphics card to run this at full tilt :D

    I have nothing but thanks for you Ralph, you are so helpful and knowleadgeable, and I really appreciate that you put in the time.
    I also see Vorpx not only for what it is now, but for what it will be as it grows, it’s an awesome product and I’m glad I’m now getting used to it.

    Best, Hugo

    #202367
    TylerDurden
    Participant

    Im having the same issue with social club, game works fine with VORPX off. But when on i get error 4. I am using a cracked game, so i imagine its probably a conflict of vorpx and the social club bypass. Not sure if anyone else has this? (And before someone says buy the game, yes thats a option. But i already own the game on ps4. Not a fan of buying multiple versions of the same game). Id appreciate any advice and help with this, thanks

    #204595
    vadzvnik
    Participant

    Hi, I have the same issue with social club error 04.
    You wrote you fixed it after 2-3 days but didn’t write it how.
    Could you please post here steps to fix the error?
    Thank you in advance

Viewing 13 posts - 16 through 28 (of 28 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!