Red Dead Redemption 2 FullVR with FOV mod

Home Forums Game Hints and Settings Red Dead Redemption 2 FullVR with FOV mod

Viewing 15 posts - 1 through 15 (of 39 total)
  • Author
    Posts
  • #189963
    dellrifter22
    Participant

    Red Dead Redemption II FullVR Guide (Z3D)

    For maximum FullVR immersion in RDR2, I’ve configured custom profile settings to work best in conjunction with the FOV mod now available. Many thanks to Ralf for the excellent profile and PCGamingWiki for the mod tool.

    Unfortunately, off-screen HUD is still a struggle, so I recommend you first become familiar with the common context button situations to avoid frequent edgepeek use. Then when ready, You can try these cloud settings for a “deep in the saddle” experience.

    So far, this is geared for best efficiency with HP Reverb, but may work similarly with other headsets. It’s a few extra steps of setup, but worth it 😎:

    Prepare Mod
    – Download and extract Widescreen FOV Mod from PCGamingWiki
    (as always, remember that modding is at your own risk and should not be used for Online play)
    – Add mod exe to vorpX Excluded Programs (we don’t want to hook this)
    – Import Red Dead Redemption II [dellrifter22] settings from vorpX cloud

    Custom Size Resolution
    – Create a 10:9 resolution and apply it to your monitor in Windows Display Settings
    3200×2880 = quality (my recommended for Reverb)
    2400×2160 = balanced
    1600×1440 = performance

    In Game Settings
    – Select custom resolution and set Windowed Boarderless (to avoid squish)
    – Set TAA to Medium (High becomes blurry) and TAA Sharpen to max
    – Reduce Headbob in Camera settings
    – Set 1st person FOV to max, but 3rd person FOV down to minimum

    Activate FOV Mod
    – Load into your saved game world
    – Alt+Tab minimize game, open and run the mod exe
    – Back in game, enter 1st-person (V key) and equip revolver/pistol
    – Press F3 to enable mod, then hold F8 to increase view until you barely start to see Arthur’s shirt sleeve – looking down with your right eye.
    – F8 to increase, F7 to decrease

    I wish I could save specific number values with the mod tool, but for now we just have to eyeball it each time. Ultimately, set it to what ever is most comfortable for you, but understand that setting it too high or too low will impact the 3D effect and scale accordingly.

    So far these settings are looking great for both 1st and 3rd person, so you can switch on the fly as desired. Thanks to the narrowed resolution, cutscenes look fine in fullscreen and shouldn’t often need edgepeek.

    *Remember Alt+C to hide/reveal mouse cursor as needed, and middle mouse or right stick click to EdgePeek for HUD.

    Okay, I think that’s the bulk of it for now. I’m sure we will all continue to find improvements and tips as we play, so feel free to share your findings with everyone here. Saddle up boys and enjoy!

    Shout out to Beardo Benjo for spreading the word on youtube. Here are some more of his impressions playing vorpX FullVR…

    #189964
    dellrifter22
    Participant

    Forgot to mention, in case you have already saved an image zoom value to the previous profile, FullVR image zoom is meant to be at 0.90 for these settings to look correct.

    So check the Image Settings page of delete key menu that image zoom reads 0.90, which should fill the entire screen view of HP Reverb.

    #189979
    Ralf
    Keymaster

    Thanks for putting this together. I pinned the thread for now, hope you don’t mind. :)

    Providing a scalable HUD option for DX12 is next up on my task list, I think that would be the most important improvement from the current state of affairs.

    #189999
    forlaunchcast
    Participant

    dellrifter22, thanks so much for doing this.

    Yes, I’m a fellow Reverber. In fact, a huge factor in my getting the Reverb was for its use with vorpx, especially given the dearth of AAA VR titles. In vorpx, there’s enough hours of AAA gaming to last 5 lifetimes. Ralf, HP really should give you a kickback…

    Have a 2070 Super and run all my vorpx games at 3840×2160 which thankfully matches my 4k TV resolution. Still fiddling with the RDR2 settings to eke out the highest fps and hoping Rockstar throws out a performance patch in the near future.

    See you in Wild West!

    #190004
    calvincrack
    Participant

    Thanks for the profile and instructions. I am amazed with how well it’s working at this early stage (nice work Ralf). The challenge now is to stabilize the FPS. I am on a 2080ti + 8700k and at 1600×1440 with everything low or off I can get fairly smooth performance with huge judders creeping in when I approach NPC’s, towns or camp.

    #190008
    dellrifter22
    Participant

    Wow, that would be great Ralf! Scalable HUD would make this much more functional. At the very least, a simple mod that can allow the HUD safe-zone lower than 90% as the in game settings permit. I tried looking for a value in the system.xml but couldn’t find one.

    @ forlaunchcast: I think the Reverb is prime for vorpX. It’s comfy and convenient to wear, impressive high fidelity screens, and more importantly, a modest FOV great for FullVR. My Pimax8k has awesome FOV, but realistically only few vorpX games can handle that, so you end up seeing the screen edges way too much. My Reverb isn’t perfect (right eye has a few dead pixels and a touch of mura), but overall I’m enjoying the crisp stable image, with quite acceptable brightness and color.

    If you get a chance, try running a resolution even higher than 2160p for any game, and you’ll discover how quality and clarity can still improve much beyond 4k. At 2880p, games begin to look as clear as looking at my 1080p monitor. ACOdyssey I’m running 16:9 5120×2880 (double my 2560×1440 monitor) and it looks fantastic. It comes at a framerate cost of course (averaging ~35fps which is my personal tolerance) that may not be acceptable to many, but the potential is there for future processing power to grasp.

    I’ve never tested if TVs allow this, but most monitors can imitate higher than native resolutions. Using Nvidia Control Panel you can create and test virtually any res or ratio you want, and if your display passes, you can use that for games. Anyway, sorry for the wordy response, just wanted you to know that that RDR2 begins to look good at 2160p, but man it starts looking great at 2880 if you can manage.

    @ calvincrack: I haven’t tried all Low yet myself, but it’s possible that low settings lean more on CPU and are not taking advantage of your monster GPU. See if a mix of medium to high settings do anything to even out performance.

    It’s a lengthy watch but if you’re interested, Digital Foundry goes through all the settings explaining performance impact. At the 25:38 marker a chart is displayed for the settings equivalent to the Xbox One X, which may provide a good balance.

    My take away was: reduce reflections,volumetric effects, and water physics. Medium SSAO, disable volumetric Ray, and dial back grass distance about half way.

    At 3200×2880 my 2080ti is targeting 35-45 fps, which is my personal sweetspot. I may experience hiccups in a random open field at times, but I have not felt any severe impact entering Valentine town for example.

    Head tracking at the moment seems to introduce unavoidable stutter reguardless of framerate, so best to use mouse rotation for turning. Hopefully experimenting a bit more with graphic settings can iron out your stability.

    #190148
    dellrifter22
    Participant

    If you are getting crashes after RDR2’s November 14th update, re-download the new 3.2 version for the FOV mod from PCGamingWiki.

    If you are getting choppy motion, toggling off vorpX Direct Mode Async may help. This setting is found on the Display Settings page of the delete key menu.

    The new patch seems to help with performance, but if you still have additional stuttering, you might enable async compute in RDR2’s system.xml. Not sure if this only applies to Vulkan, but it has helped some gamers.

    C:\Users\(user)\Documents\Rockstar Games\Red Dead Redemption 2\Settings… system.xml

    <asyncComputeEnabled value=”true” />

    Another possibly useful patch note that I haven’t tried yet:
    *Added an additional launch argument (-cpuLoadRebalancing) to rebalance workload on the CPU cores and avoid hitting an edge-case in certain NVIDIA graphics card drivers that causes significant stalls on 4-core and 6-core CPUs.

    Hope everyone has been able to resolve their launch issues and are now enjoying the game. I am for sure.

    #190215
    calvincrack
    Participant

    I think you were right about running at higher resolutions because I’m having a much better time at 3200×2880. Turning off Direct Mode Async also did the trick and I have the launch argument set -cpuLoadRebalancing. Some combination of these factors has helped because the game looks great now, thank you!

    #190233
    luq911
    Participant

    How I should create a 10:9 resolution? I don’t see this option in Windows Display Settings.

    #190234
    forlaunchcast
    Participant

    Nvidia Control Panel (I see it when right clicking on desktop) ==> In Display/Change Resolution, select Customize ==> Create Custom Resolution ==> *Follow Screen Prompts*

    Tried 3200×2880 and does look good. Getting some flicker issues unfortunately (everything off/low except High Textures), so I think that resolution may be beyond my PC’s capabilities.

    My big issue is loading time….when not in vorpx, game loads in 20-30 seconds, but in vorpx, man, game takes 3-5 minutes to load. Very weird.

    #190259
    rich0550
    Participant

    Thanks for posting this, how about using flawless widescreen instead since it has nice sliders and stuff? and can do fov profiles.

    #190265
    matteo39
    Participant

    CAN I RUN IT WITH A GTX 1060 ON CV1?

    #190308
    Baktus
    Participant

    I play with gtx 1060 and cv1, low settings. For me its more than fine :)

    #190389
    rich0550
    Participant

    that widescreen mod is getting “severe virus” or whatever from windows defender it is deleting it each time now

    #190427
    dborosev
    Participant

    Yeah everyone gets the virus thing, since its pretty much mimicking virus behavior to accomplish what it needs to do. Supposedly its ok. You can tell defender to allow it if you want.

Viewing 15 posts - 1 through 15 (of 39 total)
  • You must be logged in to reply to this topic.