Streaming RDR2 to Quest via Virtual Desktop

Homepage Forums Technical Support Streaming RDR2 to Quest via Virtual Desktop

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #194485

    Hi all, hopefully someone can help me. I’ve only just purchased VorpX so still trying to get my head around how it all works.

    My end goal is to play RDR2 on my Oculus Quest via Virtual Desktop.

    What i’ve tried is starting up Vorpx, starting SteamVR and then starting RDR2. However, because it’s not a SteamVR game, it just starts in “Cinema mode” – so 2d.

    I feel like i’m missing a step somewhere – or that VorpX isn’t attaching to the program? Any help would be appreciated.


    I didn’t try that myself, but you would almost certainly have to select “SteamVR” as device type in the vorpX config app for this.

    Alternatively you can stream to your Quest wired via Oculus Link with any Link capable USB3 cable. The charging cable that comes with the Quest isn’t, but most $10+ USB3 data cables are. Alternatively Oculus sells a dedicated fibre optics cable.

    BTW: I removed your other post regarding the same matter. No double posts please. Thanks.


    Ok, so I bought myself a cable, and setup link.

    When I set vorpX to Oculus, I get an error saying D3D12 Steam games do not work in Oculus mode. When I try using SteamVR mode I get the same “Cinema” display as before.

    Should I not have purchased the game through steam? Is there a workaround to get this working?


    Damn, didn’t think about that. Unfortunately DX12 currently indeed requires vorpX to run in SteamVR mode, which is no problem for other Oculus headsets. For now the only solution might be to get VD streaming working correctly.

    Pretty much all other games will work in native Oculus mode though. RDR2 currently is the only officially supported DX12 game, DX9-11 and OpenGL are not affcted by this.

    Since I’m not really sure whether you are speaking of the vorpX cinema mode, or Steam’s VR cinema, you might also want to try a factory reset in the vorpX config app. Just in case you changed the vorpX settings to cinema mode earlier. Per default the profile is using the ‘Immersive Screen Mode’ play style (recommended), but also works with ‘FullVR’. You can change that in the vorpX ingame menu.


    I managed to get a refund via steam and instead purchased the game through the Rockstar launcher.

    So I’m now using the Oculus setting on vorpX.

    I managed to find the in-game menu and try the three viewing options (immersive, cinema and full Vr) and with all of them I can see the edge of the screen.

    I assumed I was in cinema mode previously but I wasn’t. It looks pretty much the same apart from in cinema mode I can see chairs too!

    I feel like I’m missing something obvious.


    The game has a restricted maximum field of view. In FullVR mode vorpX has to match the game FOV to your headset’s FOV, otherwise the image becomes ‘zoomed in’ and distorted. If the game FOV can’t be set high enough to match your headset’s FOV, that is compensated by scaling down the image, resulting in top/bottom bars.

    In a lot of supported games vorpX can take care of that in better way, but not in this one unfortunately. As far as I’m aware a FOV mod exists for the game though, which would allow you to raise the FOV and scale up the image accordingly if you can’t live with the black bars.

    You can find more information regarding FOV and the various methods to tackle it in the vorpX help (‘Essential Hints Guide’). If you haven’t done so already, I would highly recommend to read this guide. It explains a few basic concepts and helps to avoid unnecessary trial and error.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!