Xbox gamepad settings in Bioshock Direct VR

Home Forums Technical Support Xbox gamepad settings in Bioshock Direct VR

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #127630
    jtlindeman
    Participant

    Hi,

    I’m wanting to use the Xbox Gamepad in Bioshock with Direct VR. After scanning, the gamepad works somewhat, but several actions in the game aren’t functional with the default gamepad mappings. I’ve looked through the different Vorpx menus but I’m not finding a way to change the mappings for the Xbox buttons.

    Is there a specific way I should be going about this? Right now I’m starting the game and loading a level, then doing the Direct VR scan, then turning off the Vive controllers in the Vorpx menu. The option to turn on the Gamepad via the in game menu won’t work after the scan, but I’m guessing that shouldn’t be used anyway?

    Any help would be appreciated, thanks.

    #127782
    jtlindeman
    Participant

    Sorry to bump this thread, but does anyone have any insight on this? I bought vorpX almost solely to play Bioshock and its pretty clunky using Vive controllers, which is why I’d like to use an xbox gamepad.

    Thanks!

    #127803
    Ralf
    Keymaster

    With Dirct VR the gamepad can be used natively, the vorpX gamepad override is automatically disabled after the scan. You should be able to make any adjustments to the controller mappings in the game’s options normally with Direct VR enabled.

    #127804
    jtlindeman
    Participant

    Thanks for the response Ralf.

    The issue is that once I do the Direct VR scan, the option to use a gamepad is disabled in the settings and there is no way to adjust any of the button mappings in game. It’s still possible that I’m going about it the wrong way. Could you possibly give me the order of steps I should be following

    Like:
    1. Load level
    2. Run DirectVR Scan
    3. etc….

    It would be very helpful and then I’d know if the problem is how I’m trying to accomplish it on my end.

    Thanks again!

    #127806
    Ralf
    Keymaster

    Please check whether the gamepad is activated in the game’s options.

    With Direct VR enabled vorpX does not interfere with the game’s native gamepad handling in any way. The vorpX gamepad options aren’t visible in that case because they are not necessarry with Dirct VR.

    #127807
    jtlindeman
    Participant

    It won’t let me activate the gamepad in the options, it’s as though it doesn’t recognized that its plugged in once I do the DirectVR scan.

    #127808
    Ralf
    Keymaster

    That sounds extremely odd. Not sure what to recommend, sorry. As said above, vorpX doesn’t interfere with the gamepad in any way once Direct VR is enabled.

    I’ll check whether there may be some bug, but I’m 99.9% sure Bioshock works exactly as it should in this regard.

    #127809
    jtlindeman
    Participant

    Ok thanks, I found it odd also. That’s why I was wondering if I was doing something wrong. I’ll continue to mess around with it.

    #127822
    jtlindeman
    Participant

    Hey Ralf,

    I just tried it again, and if I enable the gamepad before doing the scan it will allow it to work. However, many of the buttons on the gamepad still aren’t working after the scan, like A, X, B. I’m stumped at this point.

    #127824
    jtlindeman
    Participant

    Sorry for the triple post, but it appears that even the emulated gamepad on the vive controller isn’t working properly either. I’m getting by with the KB/M emulation on the vive controllers for now.

    #128127
    ominouswanderer
    Participant

    I’m having the exact same issue but in Skyrim. It appears that when I enable direct vr it changes the gamepad settings from the normal in game keybinds to the emulated vorpx keybinds. If I then go back and disable direct vr the gamepad works perfectly normal again.

    It’s almost as if there is a bug that is sometimes forcing the override x-box gamepad setting to be forced on as the gamepad works the exact same way it does in direct vr as it does with this setting. As an additional note, this only happened recently since I got the vive controllers so there may be some bug with the gamepad settings that are specific to those conflicted with the other gamepad settings.

    Ralf – any idea? As a quick band-aid if you could add an update that allowed the override game pad setting to be changed on and off that might fix it.

    EDIT – I was able to fix the problem by changing the override game pad setting to hide. OK & Save, then restarting the game and then re-enabling direct vr.

    #128137
    ominouswanderer
    Participant

    Seems like it was a bit of a fluke as I can’t reliably get the controller working again. The controller works perfectly fine when not in direct mode but as soon as that’s enabled the keybinds go back to the emulated mapping instead of the in game keybinds.

    Unfortunately this means I can’t use vorpx until it gets fixed as many games are missing vital keybinds with this setup and there’s no way to change the keybinds in direct mode that I can figure out.

    #169361
    Eophin
    Participant

    Same is happening for me in Bioshock. VorpX does override my XBox 360 Gamepad after a DirectVR-scan.

    -> In my case it’s working again, if I reconnect it after the scan (I take out battery pack and put it back in). Maybe it’s working with a replug for wired controllers, too.

    #170010
    gratefuldave54
    Participant

    Hi, same issue here with Bioshock. Non vr works perfectly but in vr gamepad wont work at all.

    #170013
    gratefuldave54
    Participant

    Hello again. It works ok if I unplug and plug back in the controller immediately after the direct vr scan but I have to do this every time I start a new level.

Viewing 15 posts - 1 through 15 (of 19 total)
  • You must be logged in to reply to this topic.