Abysmal performance

Homepage Forums Technical Support Abysmal performance

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #207538

    These are my PC specs:

    Monitor Resolution: 2560x1440p
    CPU: Ryzen 5 5600X
    RAM: 32GBs 3200Mhz (16-18-18-36)
    GPU: RX 6800XT
    Windows 10 Pro (Clean install)
    NVME 2TBs HP EX920
    Antivirus disabled

    I’m trying to play Max Payne 3 with default profile
    Every setting in the lowest possible value
    Lowered resolution to 1920×1080 or even to 1200x720p

    I’m getting 12FPS sometimes 20FPS

    With Shadow of Tomb Raider (default profile) I’m getting 28 FPS

    Obviously both games work with more than 100FPS without VORPX

    Is this normal and expected? or what can I tweak in VORPX to get a enjoyable playtime?



    no it’s not normal at all, something is really wrong.
    i also noticed that my games with vorpx are not as smooth as before.
    i have no idea why.
    i have a rtx 3090, some pple blame latest nvidia drivers for big drop in performance, i tried to revert back to 472 drivers but it’s still the same.

    vorpx reprojection system seems to be broken for me, alt fast, fast doesnt change anything. games are sluggish.


    Thanks for your feedback.

    I found even 2 or 5 FPS ?! with lowest settings, without Vorpx everything at Ultra 200+ FPS so definitively something is wrong.

    BTW using Z3D makes no difference (well some 10FPS gain) still unplayable.

    I’m using Oculus Rift CV1


    That’s definitely not right. First thing you might want to check is whether the issue also occurs in ‘Generic 3D-Display’ mode, wihich shows a SBS-3D image on your desktop. That way you could determine whether the issue is related to the actual game rendering (also occurs in ‘Generic’ mode) or to the headset rendering (doesn’t occur in ‘Generic’ mode).

    In the first case primarily check whether you maybe have some tool installed that also hooks into games and by doing so could potentially cause a conflict with vorpX. The trouble shooting guide above (or in the vorpX help) has more details on that. That includes any FPS counter tools. Use the vorpX FPS counter instead (ALT+F).

    In the second case also do the above, but in addition check whether maybe another headset type selection in the vorpX config app helps. Oculus headsets work with all three types, WMR headsets work with both OpenXR and SteamVR, native SteamVR headsets (e.g. Index, Vive, Pimax) also work with SteamVR and OpenXR, the latter with the unfortunate caveat that Valve seems to think noone needs 32-bit OpenXR anymore. At least they constantly ignore according requests since ~1.5 years now.


    Hi Ralf

    Thanks for answering and sorry for my very late answer (almost 1 year later)
    I’ve been busy working :)

    You point me to the right direction and I found the reason of this.

    a) SOTTR is forcing vsync always killing the performance
    I was able to disable it forcing in the AMD Adrenalin to OFF
    b) Enabled a couple of tweaks like Radeon Super Resolution
    Going from 2460×1440 to 1920×1080 and Fidelity CAS (no penalty in Graphics quality)

    With these settings I’m getting 80FPS. (Besides sometimes drop to 30FPS suddenly) but is playable in G3D.

    BTW I forgot how amazing is SOTTR in 3D

    Thanks Ralf

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!