AC Black Flag G3D not working (but Freedom Cry works)

Homepage Forums General vorpX Discussion AC Black Flag G3D not working (but Freedom Cry works)

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #200574

    Hi all!

    I’ve been playing through the Assassin’s Creed series with vorpX, and I’ve hit a snag for Black Flag.

    I’m using the official vorpX profile (using G3D), but the screen is completely flat. The HUD has a default depth of 0.8, and this is visibly closer, but everything in the game itself is flat.

    I decided to try out the Freedom Cry DLC as a test, and strangely, Freedom Cry works perfectly! I am able to see beautiful G3D depth in Freedom Cry without changing any settings at all. When I go back to Black Flag, though, everything is flat again.

    Here’s my info:
    – Steam version of the game.
    – vorpX v21.1.1
    – DirectX 12 installed
    – Running at 1920×1080 (though no other resolutions seem to make a difference).
    – All other graphics settings are default.
    – CPU: Core i9-9900K
    – GPU: GeForce RTX 2070
    – Headset: Quest 2

    I’ve been able to play all of the previous AC games in vorpX successfully, albeit with some tweaking here and there. Any thoughts as to what’s going wrong with Black Flag? Maybe the game has been updated since the vorpX profile was released? Or perhaps there’s a DirectX version issue of some kind?

    Thanks so much, all!


    UPDATE: I’ve found a solution to the issue.

    It seems that, when you start the game, you must start on a 3D scene in order for vorpX to activate G3D properly. The very first scene of Black Flag is simply a screen that reads “Ubisoft Presents”, and I’m guessing that this little bit doesn’t have any 3D information for vorpX. If you continue playing from this point, the game remains flat forever.

    If, however, you finish the first sequence, quit, and reload the game, everything works fine. Presumably, loading into a scene with 3D information gives what vorpX needs to “kick in”, and G3D works fine after this. You can even restart the game at this point and G3D remains active.

    As a side note, this also appears to explain why Freedom Cry works. The DLC starts in a 3D scene, so there are no problems.

    My explanation here is likely not quite right, but this does seem to be a good solution to this issue. I hope it helps someone else.

    @Ralf : I’d love to get your take on this. Is this perhaps a bug that could be fixed? Or is there some other reason you can think of that would be causing this issue? Thanks!


    Thanks for the tip…!!!
    I tried Black Flagg and wondered why it doesn’t generate a G3D but stays flat …
    I will try it today … I’m curious … Thank you very much !!


    No prob, and hope it works for you! Black Flag is frickin’ gorgeous with vorpX. Sailing as a pirate in the Caribbean feels like a vacation. =D

    Good luck!


    Didn’t have much time to test the game yesterday … then made the mistake of your hints with the logo and then stopped thinking about canceling the game …
    Will start a detailed experiment tomorrow evening …
    It’s a shame that “Ralf” does not comment on it … well maybe it is also a time or priority problem for him. “Smile”

    3D VR greetings


Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!