Are custom resolutions still working?

Homepage Forums Technical Support Are custom resolutions still working?

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #215630

    Hello everyone,

    I’m trying to use custom resolutions that exceed my monitor’s 1080p to be able to fully enjoy the 2448×2448 resolution of my HTC VIVE Pro 2. However, whenever I set a resolution that is higher than 1080p, like 2560×1440, the game starts stuttering massively and becomes absolutely unplayable OR nothing changes (definition doesn’t increase nor FPS decrease).

    I have even struggled setting aspect ratios that are not officially supported by the game, even if below 1080p.

    I tried applying the custom resolution to my PC’s main monitor before appliying it in game, but the results are the exact same.

    The interesting fact is that without vorpX they actually work just fine, it’s only when I launch the game in my headset that I get the massive stuttering (only inside the headset) or no effect at all.

    Games I tested:
    – Forza Horizon 4 / 5: Massive stutters all the time (head tracking extremely laggy, which happens in 1080p as well to a lesser extent)
    – Rocket League: Massive stutters when lots of things are moving on the screen
    – Tiny Tina’s Wonderlands (same engine as Borderlands 3): nothing changes, can only change from 16:9 to 16:10 applying custom resolution to my monitor prior change in game

    Any suggestions?

    Thanks in advance,


    Keep in mind that 2448×2448 compared to 1920×1080 means 3x the number of pixels. (~6 megapixels to ~2 megapixels), which not only raises the GPU workload, but also the required GPU memory significantly. Try to find a balance that works for your system.

    On a sidenote: exactly square resolutions are a bad idea, IIRC vorpX displays a warning in such a case. Messes with some 3D heuristics (e.g. shadow detection), which may also affect performance. Never dial in an exact square resolution, always use something that is at least 5% wider or narrower. To keep things simple use a 4:3 res, which also avoids issues with games that only want common aspect rations.

    If you happen to use the beta, use the virtual monitor. It’s main purpose is to make sure you never have to dick around with custom resolutions yourself anymore.


    The fact is that no resolution above my monitor’s 1080p works at all when using vorpX, doesn’t matter the aspect ratio. I tried the classic 2560×1440 16:9 and it still doesn’t work.

    I don’t know what virtual monitor is, nor how to look for the beta. My vorpX version is 21.3.3.
    How do I access the virtual monitor / beta?


    EDIT: I’ve just found the vorpX 23.1.0 BETA thread here on the forum. Gonna test and see if things get better!

    Disco Machine

    Did it get better? I have a similar issue.


    @Disco Machine I found that some games do accept custom resolutions above your monitor’s native resolution, even if you don’t set such higher res from nVidia control panel before starting the game (e.g. Forza Horizon 4 / 5). Make sure your GPU doesn’t reach too high utilization % though, otherwise vorpX will not have enough resources to work its magic.
    For those games that don’t accept custom resolutions, you have to hope they have a Super Resolution option. Basically set a resolution with the aspect ratio you want and then increase it by increasing the super resolution %. For example in Tiny Tina’s Wonderlands I set the base game res to 1280×1024 and then increased it by setting the resolution scaling slider to 175%.
    There might be a way to force super resolution from nVidia control panel if the game doesn’t have the option itself, but I can’t guarantee it will work.
    Newer titles allow the user to directly dial in the Render Resolution in the game option so if the game you want to play supports that, it’s definitely the best situation as you can adjust aspect ratio and res with a single option in game.

    Hope it helps :)

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!