Arma 3 doesn’t work DK2

Homepage Forums Technical Support Arma 3 doesn’t work DK2

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #16533

    My DK2 doesn’t work with Arma3, When I lunch the game i’ve got just 1 screen, not 2 for 3D. Please help me


    Hey Walkn51, I have the same issue. The only workaround I was able to achieve was to drop the resolution in A3 to 948 x 1080 which apparently puts the Rift into some sort of 2D mode. Working out the main menu nav is still a pig but you can adjust the HUD, which is handy.

    To adjust the FOV you’ll need to go into <profilename>.Arma3Profile in your My documents/Arma 3 folder and use a tool like this:,A3.htm to calculate the values and entries you’ll need (using the afforementioned resolution). I went for an FOV of 95 which was closer than not.

    So it’s 2D, but still pretty damn immersive. Mouse emulation means that body / head movement is not decoupled, double-tapping left alt does a pretty good job though.

    Makes me think a rift-track to mouse / freetrack emulator standalone tool would be handy…


    Thanks for the feedback face9.
    I tried it, but when I enter 948×1080, it doesn’t mirror the image.
    Can you confirm any custom settings?
    Running different version of directx ingame?
    What are your Vorpx settings?
    Did you set any particular aspect ration in A3?

    Any feedback would be appreciated, thanks!


    Hi Renifizzle,
    I assumed it was some sort of cleverness that was being handled by the Rift, not Arma, but I’ll have a play tonight and get back to you. Is the image just not being duplicated or is it the wrong rotation?

    What GFX card are you rocking?


    It is not being duplicated. I have even used the “create desktop shortcut” with vorpx.

    The vorpx overlay and ‘del’ key are working fine, just no screen split. I have the resolution in 948×1080 as well.

    I have an R9 270. I have 2 in crossfire, but it is temporarily disabled.


    Also, DayZ SA seems to work great with the rift.


    Damn, think it may be an Nvidia thing in that case; I found I can set the rift desktop to 948 x 1080 in the NVIDIA control panel and it’ll go into duped / 2D mode. :/


    I figured it out. I have to go into Catalyst control center and set the rift to 120 Hz. Then it mirrors the image.

    So 2d works. Makes me a little sick but kinda cool.
    Not actually functional, you can’t see the corners of the screen and lots of relevant info there. But cool =)


    so i got the dk2 working with arma3
    it’s only 2D but it is ok :)
    i set the fov to 100 and it worked fine
    but than i installed opentrack for dk2 (independent head tracking works also good)
    but than the fov changed….
    its way to close… even when i set the fov to 180 its still too close….
    any of u got an idea how to fix that?


    Sounds like using OpenTrack overrides the game FOV. If that is true, not much vorpX can do about that unfortunately.

    BTW: The hooking issue is fixed in the meantime. With the next vorpX update ARMA III will work without workarounds again.


    thank u ralf

    can u tell us when the next update is going to be?


    There is no relase date set yet, so the answer is the good old ‘when it’s done’. ;)

    Your vorpX will auto update when the next version becomes available.


    Hi all,

    New user here. Has Vorpx been updated since September 12th? Just wondering if I can use this software with ARMA3 yet?


Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!