Assassins Creed 2 – no geometry 3d? And menu FPS problem

Homepage Forums Technical Support Assassins Creed 2 – no geometry 3d? And menu FPS problem

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #167701

    I did want to Play some old AC games and did start with the first game of the series, which runs perfect in geometry 3d mode.

    Then i did start AC2 and in the welcome info it does state that it Supports geometry 3d, but it does not show this option in the menu, only Z-Buffer 3d.

    Then i did try to use the profile of AC1 for the AC2 executable but because steam starts uplay and uplay always starts the original AC2-exe, renaming this exe to use my user profile on it does not work.

    So, is there a way to alter/delete the default Profile?
    Why is AC2 not using geometry 3d in first place?

    One more thing i discovered:
    As soon as i bring up the vorpX-menu with del, the game beginns to stutter and i lose roughly 20% of my fps. It does not improve if i close the menu. Once the menu is opened, big stutter – unplayable. So i tweaked everything and now i run AC1 without opening the menu. Alt-f or alt-space for recentering the view does not cause the stutter…

    So far i only experienced this behaviour with the AC (1,2,3,4) series…

    I crosschecked with other Headsets – i used the Pimax 4k with ist own renderer and the VIVE with the steam renderer – but no difference.

    Any ideas?

    Thank you!


    Same problem here with AC2 (original DVD version, so Steam is not the culprit). The vorpX popup says right at the beginning that the game has Geometry 3D, but then the option isn’t available: only Z3D.

    I am a sad panda, because to me Geometry 3D makes all the difference…

    Ralf, when you have some time could you check on this? If G3D was implemented for the game, is there a trick for making the option available?


    If it’s any help, there is a suspicious entry in the vorpX log for the game:

    WRN: Loading pre 17.3.0 G3D settings (0.0.0)

    Other lines that contain the term G3D appear normal to me:

    INF: ProgSetting User: Head Tracking G3D Latency Enhancement: 0.000000
    INF: ProgSetting User: G3D Max Separation: 1.000000
    INF: ProgSetting User: G3D Focal Offset: 0.000000
    INF: ProgSetting User: G3D FOV Multiplier: 0.000000
    INF: ProgSetting User: G3D Camera Height Mod.: 0.000000
    INF: ProgSetting User: G3D Shadow Treatment: 4

    Should I give up all hope for this great game? :’-(

    BTW, Z3D is also not working for me in AC2: Normal has zero depth regardless of the settings, and Adaptive has uniform depth (toying with the settings I can manage to push the whole world more or less “inside” the virtual screen, but there is no convergence whatsoever). It’s as if vorpX were unable to read the depth buffer.


    hi why dont u disable voprx autosettings u should be fine then…


    Thanks for the suggestion (I assumed you meant checking the “Never change any game settings” box), however I just tried and it made no difference whatsoever. In any case, vorpX doesn’t seem to have custom settings for Assassin’s Creed II: the “Restore Game Settings” list doesn’t even include the game. Out of curiosity, was yours a generic recommendation or did you find instances where leaving the automatic settings enabled would kill Geometry 3D?

    BTW, of course I also tried resetting the profile to factory default, both in the “Local Profiles” page and from the “Trouble Shooting” page (not sure whether there’s any difference between the two restoring methods), and Geometry 3D is still unavailable. For the sake of completeness, I also tried toggling the “Try to block known game overlays” and “Run vorpX Control as administrator”. Nope.


    no i just was a suggestion,, one more thing though some graphics settings can cause g3d turn off. As well as wrong fov settings ccan look like g3d setting is off. ENB is a candiate as well……just trying to give some options….

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!