Attaching to program……

Homepage Forums Technical Support Attaching to program……

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
  • #169085

    Hi there! new to the forum. I’m looking for an explanation. With the 17.3 update, I was very excited to try Star Wars: Battlefront II in full VR, however when I open the game, I just get a dialogue box that says it’s attaching. I haven’t seen this before, and it doesn’t go away. It says it will take a while however the screen stays and I have three options. What option do I select? And how long does this usually take?



    The dialog is new. If you suspect the program hangs, click the “End Program” button, if you want to wait a little longer, click the “Do Nothing” button. The “Exclude” button is for cases where vorpX tries to hook into programs it’s not supposed to hook into, so you don’t want to click that for the game.

    Please check whether maybe the game minimized itself to the taskbar and sits there idling. That can happen sometimes with Frostbite engine games. If so click on its taskbar icon to bring it up.


    Thanks for the reply Ralf.

    I hit do nothing………..and it does nothing. Is it supposed to pop into my Rift after a while?


    It shouldn’t take longer than booting up the game normally without vorpX.

    If vorpX can’t hook into it, please first and foremost check for any potential injection conflict. Hottest candidates are: virus scanners, any sort of CPU/GPU utilities, game video recording/streaming software, chat programs and generally everything that can show notifictations in games.

    Best way to trouble shoot this is to disable/uninstall any programs running in the background.



    I’ve disabled Windows Defender, additionally I added the EXEs for vorpX to the exclusion list.

    Still getting the dialogue (which I understand is normal now) however the game doesn’t load into Oculus Rift. Is there any troubleshooting documentation I can send to you to take a look at?



    Same error here with Rise of the Tomb Raider (v1.0 build 813.4_64; Steam). Hangs at ‘Attaching to ROTTR.exe / This takes quite a while…’.

    The title launcher appears first with the vorpX ‘Attaching to ROTTR.exe’ window a few seconds later (with the ‘exclude/close/do nothing’ options appearing sixty seconds later).

    Headset is stuck with the null loading window stating ‘Rise of the Tomb Raider / Loading…’ and the game icon in the bottom left.

    I was anticipating this title to be work without having to use the built-in stereoscopic SBS option in conjunction with vorpX desktop viewer.

    Tried importing cloud profile, manually adding to exclude list (doesn’t give the error but doesn’t hook either), adding steamapps folder to Windows Defender exclusions (vorpX is already there as the config app was flagged as virus with the 17.3 Witcher hotfix), running vorpX as admin, creating vorpX shortcut and adding ‘-nolauncher’ option. There’s no injection conflict processes that I can see.

    There was some noise at release about the title needing dxgi files deleted from install directory to work… worth mentioning.

    17.3 working very well otherwise.


    I can’t really recommend anything else than above, sorry guys. If vorpX can’t hook into a program, that’s usually related to some injection conflict with another program that also hooks into games.

    The very first thing to check is your virus scanner if it is anything else that Windows Defender. Apart from that typical candidates are GPU/CPU utilities, chat programs, video recording software and generally anything that can display notifications in games.

    You can create a trouble shoot archive in the config app and send that to support |at| vorpx com. That is no guarantee for a solution but I can look into it later this week.


    Can anyone provide additional information? I have tried everything. There are no overlays, antivirus is disabled, everything updated.

    I have an Nvidia card. I’ll try turning off gForce experience tonight. That’s the only thing I can think of.

    I’ll update with what happens.




    I’ve made some headway, I see a flicker in the headset after I disabled the GeForce Experience In-Game Overlay, so we’re making progress.

    I noticed that when I try to reset the game settings in the config window, the application errors and closes out. See below the error logs for the application. Appears to be a Kernel issue. Additionally, there’s a .NET Runtime issue. See below.

    Faulting application name: vorpConfig.exe, version:, time stamp: 0x5a410dbe
    Faulting module name: KERNELBASE.dll, version: 10.0.15063.726, time stamp: 0x32774c02
    Exception code: 0xe0434352
    Fault offset: 0x000ecbb2
    Faulting process id: 0x3cb4
    Faulting application start time: 0x01d37ea25212b300
    Faulting application path: C:\Program Files (x86)\Animation Labs\vorpX\vorpConfig.exe
    Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
    Report Id: 6a3e4c0b-9c2e-447a-b2d3-002ae8fe544e
    Faulting package full name: 
    Faulting package-relative application ID: 
    Application: vorpConfig.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.IO.FileNotFoundException
       at System.IO.__Error.WinIOError(Int32, System.String)
       at System.IO.FileStream.Init(System.String, System.IO.FileMode, System.IO.FileAccess, Int32, Boolean, System.IO.FileShare, Int32, System.IO.FileOptions, SECURITY_ATTRIBUTES, System.String, Boolean, Boolean, Boolean)
       at System.IO.FileStream..ctor(System.String, System.IO.FileMode, System.IO.FileAccess, System.IO.FileShare, Int32, System.IO.FileOptions, System.String, Boolean, Boolean, Boolean)
       at System.IO.StreamReader..ctor(System.String, System.Text.Encoding, Boolean, Int32, Boolean)
       at System.IO.StreamReader..ctor(System.String, System.Text.Encoding)
       at System.IO.File.InternalReadAllLines(System.String, System.Text.Encoding)
       at System.IO.File.ReadAllLines(System.String)
       at vXcHCljRRRoUcBcugGiNxmgxOSjE.‌​‌‬‫‫‌‮‮‭‏‍‎‍‫‏‬‏‍‮‪‭‮‮‎‫‭‪‮‮()
       at vXcHCljRRRoUcBcugGiNxmgxOSjE.‫‍‬‌‌‍‫‍‌‫​‫‏‪‮‬‬‍‮‌‮‬‎‌‍‮()
       at vXcHCljRRRoUcBcugGiNxmgxOSjE.‪‭‍​‫‫‬​‮​‏‬‎‮‎​‫​‍‏​‭‭‮()
       at vXcHCljRRRoUcBcugGiNxmgxOSjE.‫‍‮‭‏‬​‏‏‎‎‭‮‏​‮‭‍‭‍‫‫‌‏‏‮‍​‪‮(System.Object, System.Windows.RoutedEventArgs)
       at System.Windows.RoutedEventHandlerInfo.InvokeHandler(System.Object, System.Windows.RoutedEventArgs)
       at System.Windows.EventRoute.InvokeHandlersImpl(System.Object, System.Windows.RoutedEventArgs, Boolean)
       at System.Windows.UIElement.RaiseEventImpl(System.Windows.DependencyObject, System.Windows.RoutedEventArgs)
       at System.Windows.UIElement.RaiseEvent(System.Windows.RoutedEventArgs)
       at System.Windows.BroadcastEventHelper.BroadcastEvent(System.Windows.DependencyObject, System.Windows.RoutedEvent)
       at System.Windows.BroadcastEventHelper.BroadcastLoadedEvent(System.Object)
       at MS.Internal.LoadedOrUnloadedOperation.DoWork()
       at System.Windows.Media.MediaContext.FireLoadedPendingCallbacks()
       at System.Windows.Media.MediaContext.FireInvokeOnRenderCallbacks()
       at System.Windows.Media.MediaContext.RenderMessageHandlerCore(System.Object)
       at System.Windows.Media.MediaContext.RenderMessageHandler(System.Object)
       at System.Windows.Threading.ExceptionWrapper.InternalRealCall(System.Delegate, System.Object, Int32)
       at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(System.Object, System.Delegate, System.Object, Int32, System.Delegate)
       at System.Windows.Threading.DispatcherOperation.InvokeImpl()
       at System.Windows.Threading.DispatcherOperation.InvokeInSecurityContext(System.Object)
       at MS.Internal.CulturePreservingExecutionContext.CallbackWrapper(System.Object)
       at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
       at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
       at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
       at MS.Internal.CulturePreservingExecutionContext.Run(MS.Internal.CulturePreservingExecutionContext, System.Threading.ContextCallback, System.Object)
       at System.Windows.Threading.DispatcherOperation.Invoke()
       at System.Windows.Threading.Dispatcher.ProcessQueue()
       at System.Windows.Threading.Dispatcher.WndProcHook(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)
       at MS.Win32.HwndWrapper.WndProc(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)
       at MS.Win32.HwndSubclass.DispatcherCallbackOperation(System.Object)
       at System.Windows.Threading.ExceptionWrapper.InternalRealCall(System.Delegate, System.Object, Int32)
       at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(System.Object, System.Delegate, System.Object, Int32, System.Delegate)
       at System.Windows.Threading.Dispatcher.LegacyInvokeImpl(System.Windows.Threading.DispatcherPriority, System.TimeSpan, System.Delegate, System.Object, Int32)
       at MS.Win32.HwndSubclass.SubclassWndProc(IntPtr, Int32, IntPtr, IntPtr)
       at MS.Win32.UnsafeNativeMethods.DispatchMessage(System.Windows.Interop.MSG ByRef)
       at System.Windows.Threading.Dispatcher.PushFrameImpl(System.Windows.Threading.DispatcherFrame)
       at System.Windows.Threading.Dispatcher.PushFrame(System.Windows.Threading.DispatcherFrame)
       at System.Windows.Application.RunDispatcher(System.Object)
       at System.Windows.Application.RunInternal(System.Windows.Window)
       at System.Windows.Application.Run(System.Windows.Window)
       at ‫‭‌‪‭‌‍‮‬‍‪‮‭‮‪​‎‬‏‮‭‌‍‌‮.‌‬‎‮‫‭​‏‪‪​‫‮​‎‬‌‎‌‫‫‏‫‏‭‮()

    The config app issue is almost certainly unrelated to your hooking problem. It doesn’t have to be running for vorpX to hook into games.


    Thanks to the developer for coming back so quickly on this issue.

    @Bruce; we’ll find a solution to this… let’s keep at it.

    Maybe if anyone else is getting this attaching error they could chime in.


    Figured out, it’s because DirectX 12 was turned on.

    VorpX does not work with DirectX 12.

    Simple mistake.


    I’m from Spain and my English is bad. I don’t understand you said, but I have the same problem and nothing works in vorpx. Many games doesn’t work.
    Attaching to… resident evil 7
    Attaching to… battlefield 4

    and more…

    Please, I need help. Use a easy English to me please.


    If vorpX can’t inject into multiple programs, there likely is an injection conflict with some other program on your PC.

    Hottest candidates are: virus scanners, any sort of CPU/GPU utilities, game video recording/streaming software, chat programs and generally everything that can show notifictations in games.

    Best way to trouble shoot this is to disable/uninstall programs running in the background.


    I found a quick FIX for those troublesome games that won’t automatically attach that should, I just casually left click as it’s booting up until it attaches. I have to do it for far cry 2 and Yakuza0 otherwise they’ll hang or go back to desktop where the active game icon does nothing, it’s a simple trick and everything works in del menu like normal.

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!