Battlefield 4 (Flickering textures)

Homepage Forums Technical Support Battlefield 4 (Flickering textures)

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #202202


    I’m having an issue with BF4 in G3D where the game hooks, and I can see it working in 3D, but most (basically all) of the main textures are missing and flickering.
    I can see the skybox and some floating debris/smoke/ash etc… but that’s it.

    Any ideas?


    No way to replicate this here. So nothing else I can recommend besides resetting both the vorpX profile and the game’s graphics settings to default. Also please check whether you maybe have a dxgi.dll or d3d11.dll in the game folder that might have been put there by some mod. If so, please remove them. vorpX should complain in that case usually, but just in case.


    I’ve tried everything I can think of.
    Upon startup I can tell it’s about to not work because even on the initial screen, the background (which is usually a bluey green) is black, and I can’t see the text to change settings.
    Also, if I try to switch from G3D to off or z3d the game crashes and I get an error popup.
    I might try a Vorpx uninstall/reinstall and see if that changes anything.


    Ok… I had ‘some’ progress.

    I’ve tried making sure overlays everywhere are off. Disabling my 2nd physical monitor. I’ve launched using the 32 bit exe etc. Tried making my desktop rez match the in game rez.
    Somehow, out of nowhere… the game finally allowed me to switch 3d off in Vorpx and not crash. I believe it was when I launched the game from the Battlenet browse, strangely enough.

    I was able then to actually see all the text and play in 2D. I could even flick between 3D and 2D at that point. And apart from a bit of flickering (tanks etc disappearing and reappearing) I could see how great the 3D looked. And 2D was perfect.

    Then I thought perhaps it was Origin. So I quit out and realized I could sign into EA Desktop and launch from there.

    And then I was back to square one. Black screens. Missing text. And crashing when trying to turn the 3D off.

    So I’m kinda lost.

    Ralf… do you use Origin or EA Desktop to launch it?


    Origin, haven’t looked into their new client yet. What you could try is disabling the Origin overlay specifically in the Origin options, although that shouldn‘t really be necessary.

    There shouldn‘t really anything special you have to do normally. All textures broken sounds as if something really fundamental is wrong. Do you by chance use 3D-Vision? If so, please double check whether it’s disabled in the nVidia control panel. Might be also worth a try to empty the nVidia shader cache in that case (C:\ProgramData\NVIDIA Corporation\NV_Cache).


    Thanks Ralf!

    No 3Dvision. I’m on an AMD card (until the 3080/ti becomes available

    Just an FYI after a LOT of toying around…

    I could consistently get the game to boot and let me switch 3D modes so long as I forced it to boot the 32 bit version in Origin.
    The only downside here is that the game won’t let you change any graphics options in 32 bit mode (which is strange).
    So, I’d have to get my settings where I wanted them in 64 bit without Vorpx, and then go back to 32 bit with Vorpx.
    Another win was, I didn’t even realize BF4 worked in Z3D, because I always had SMAA turned on.
    Suddenly I have Z3D with it off now. It’s cleaner looking with 4xSMAA obviously, but with G3D giving me texture artifacts no matter what I do, I’ll take some aliased Z3D for now!

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!