Battlefront 2 Issues

Homepage Forums Technical Support Battlefront 2 Issues

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #190872

    I just received my Odyssey+ WMR headset yesterday and am utterly new to VR, but am otherwise technically savvy. I can program, build computers, etc. I bought VorpX after reading so many rave reviews about it, but have so far had nothing but issues with it. I’m sure much of this can be blamed on the Steam VR and Microsoft issues affecting WMR devices right now, but I’m really hoping someone can help me get this figured out.

    So far I’ve tried Skyrim and Battlefront 2 (2017) and both have been utter disasters. I watched the 55-minute VorpX guide on Youtube from 2018, I’ve scoured these forums, and I’ve read and followed every tutorial and piece of advice I can find.

    With Battlefront, specifically, the game is just a nightmare to behold. I got the headtracking working ok, but the actual game looks pixelated and glitchy, with constant flickering, pop-ins, weird partical effects, etc. Is there anything I should be doing to address these issues? I’ve turned off V-Sync, though I still get the warning about it from VorpX when the game starts, telling me to disable it. I’ve lowered most of the game settings as recommended in the Youtube guide.

    Any advice for getting VorpX running, for Battlefront, Skyrim, Fallout, or otherwise, would be immensely appreciated.


    “constant flickering, pop-ins, weird particle effects, etc”

    I have this exact same issue.

    Did you ever work this out? (doubtful, considering nobody replied)

    Anyone else have flickering textures on this and figure out how to get around it?

    Ralf? Could you take another quick look at this? This is my number one game I was hoping to play. I can see it looks incredible under all the flickering.


    Please switch to Z3D (should be the profile’s default) if G3D is too glitchy. On some maps G3D works well, but on others apparently it doesn’t. With Z3D you won’t encounter such issues.

    BTW: directly switching from Z3D to G3D causes additional glitches, so either way you’ll definitely have to follow the hint shown in the menu that recommends a game restart after switching to G3D.


    Thanks Ralf…

    Crying shame, huh? Coz between the flickering, I can tell it looks amazing in G3D (like they all do I suppose)
    But the z3d aint half bad.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!