Can not get games to display on Rift only on main monitor

Homepage Forums Technical Support Can not get games to display on Rift only on main monitor

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #81031

    When I launch a game with vorpx, it comes up on my main monitor.
    I have Oculus set to extend mode. Vorpx set show on rift DK2. I have also tried oculus set a main monitor and it still comes up on my monitor not the rift. If I set the rift to Direct HMD, launching a game still comes up in my monitor. also set Vorpx to use system settings, but it still comes up on my main monitor
    How do i get it to come up on my rift.


    When you are using the DK2 as main monitor, did you set vorpX to “Use system settings”? That is vital. If it’s not done, vorpX will still try to force the game to the Rift.

    This should definitely always work, in this case DirectX just does what it always does, meaning opening games on the primary monitor whatever that is.

    Apart from that using the Rift as primary monitor normally should only be necessary in some special cases.

    Every few months I get a report of mysteriously swapped display names in the config app, maybe that’s your issue. Trying “Show on [your other monitor]” instead “Show on Rift DK2” may be worth a try. Never had the time to look into this so far unfortunately.


    I was able to get it to work in GTA 5 by setting the in game setting to monitor 2
    it would then launch to the rift when vorpx was started.
    Virtual Cinema mode works very well. only thing that is whacked out in the game is the right joystick (head look) its very jerky, not sure why

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!