Can’t hook any directx 9 games

Home Forums Technical Support Can’t hook any directx 9 games

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #197356
    Ogrescar
    Participant

    This is something that just started happening and it’s specific to direct9 only. The troubleshooting log ends with one or more
    [bold]
    ERR: D3D9 Interface: Device Creation failed: D3DERR_INVALIDCALL
    ERR: App: TopCrashHandler: unhandled exception ACCESS_VIOLATION at 0x0
    [/bold]
    messages.

    It may be related to me having multiple gpu’s, but that’s never been a problem until now. I’ve disabled and even uninstalled the drivers for the second gpu because, when this problem first started happening, direct9 games were all starting on the second gpu despite my windows settings. So, I used ddu to wipe my drivers and re-installed, and can run the directx9 games on my primary gpu now (had to uninstall nvidia drivers on the second gpu), but not with vorpx – it still fails to attach.

    I installed (or windows update installed) KB4579311 which contained security updates for windows graphics components yesterday – I don’t see how they’re related but I just noticed the directx9 behavior the day afterward.

    Anyway, I don’t play many dx9 games and I won’t be unless I can figure this out. I haven’t seen any problems with other api’s – opengl and dx11/12 games don’t seem to be affected.

    #197357
    Ralf
    Keymaster

    I’ll check the update you mentioned, apart from that I can’t really recommend much more than reverting any changes you made to your system to the state before your issue started to occur. Also please make sure that your headset is connected to the same GPU that your games are running on. Difficult to say anything more specific, the error in the log means that the actual d3d9 createdevice call failed, that pretty much never should (or even can) happen until something is severly borked, e.g. some other program also hooking into d3d9 in the same manner as vorpX.

    #197358
    Ogrescar
    Participant

    Well, I was able to fix this by setting vorpcontrol.exe and vorpservice.exe in Windows graphic settings to use the gpu that I’ve got the headset attached to. I never had to do this in the past, everything ran on my main device and trying to get something to run on the second gpu was a pain. Anyway, Windows now apparently ignores the max performance for games set in the Nvidia control panel and does whatever the hell it wants. I guess ancient direct9 games are not worthy of my main gpu anymore, but opengl and dx11/12 are okay. I wonder if Vulkan made it to the worthy list.

    #197359
    Ralf
    Keymaster

    Neither the service (actually does nothing currently, it’s only purpose was to fix an Oculus multi monitor glitch in the early days) nor vorpControl access the GPU, so I’m not sure how that could make a difference… Anyway, glad it solved your issue.

    TBH multi GPU systems are not much of a concern, but I’ll look into adding a security check that provides a meaningful error message in case of a game/headset GPU mismatch.

    #197364
    Ogrescar
    Participant

    Hmm, well I removed the vorpx components from my graphics settings, rebooted, and the problem has gone away, for whatever reason. At one time Windows said I had 2 identical gpus, one for low performance and the other for high performance, which is not the case – I think that rebooting with the second gpu disabled may have fixed it’s scheduling mechanism, except that it was more like 10 reboots later…

    I only use the second gpu for my second monitor and as a dedicated physx processor or it wouldn’t be in the box anymore. Mostly it just wastes energy and generates heat.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.