Choppy High FPS on Savage Lands

Homepage Forums Technical Support Choppy High FPS on Savage Lands

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #219293

    I am trying to run Savage Lands. The games fps are fine, but the game freezes about once per second, making it really choppy. If I look at the monitor, those freezes are not visible there, everything is smooth and high fps. Seems like something is wrong with the streaming to the Quest 3? My router is extremely fast though. Using 200mbit when using VirtualDesktop, with about 8ms network lag. Airlink also works fine, no problems there either. Any idea why VorpX lags?


    Is it a general problem with Quest 3 or a specific problem only with that game? Bought VorpX a while ago, but last time i tried it, it didn’t work well either, i believe. Don’t remember which game that was.

    Specs are:
    32gig Ram
    Rx 7900 XT

    Virtual Desktop and Airlink work fine. UEVR also works fine. Tried some more games last night, but never got a smooth experience with vorpx, despite decent fps.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!