Combinations of problems preventing my troubleshooting of Deathloop (Z3D)

Homepage Forums Technical Support Combinations of problems preventing my troubleshooting of Deathloop (Z3D)

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #207267

    Hi all,

    I’m running into an issue with the official Deathloop profile. Z3D is fine and all, but on my Oculus it works well when it’s 100% by default, but if I make a single setting modification (simple stuff like ambient background or even xbox override binds because those are pretty bad by default), I get a strange performance/freeze loop the next time I play, until I reset fully again.

    I’ve made myself about 10 profiles in the past 3 years, with great success, and always find the best I can do with Vorpx’s tonnes of settings. Since the official profile seems buggy, I would love to make my own profile, but now I get the annoying warning about the exe being used already (like in this recent thread:

    Instead of troubleshooting the official profile, I would love to be able to make my own profile, like I did for many other games, but renaming the exe prevents it from launching with Steam.

    1) Is there ANY solution for the exe thing? THAT’S the biggest problem if you ask me.
    2) Otherwise, any suggestions to fix/present the freeze > low fps > smooth fps loop?
    * Yes, I tried safe sync mode, I tried FluidSync, nothing works – it just makes things worse actually
    * No, performance is not an issue at all when using the reset official profile
    * Passing through SteamVR destroys the performance. I go from capped 90fps via Oculus to stuttering 30-60, so it’s not an option sadly.

    Any suggestions would be appreciated, because I can see that it works well with the game, but something breaks it if I do not fully reset every time I want to play it. I’ve put 120 hours into this game and am not about to pass on an opportunity to spend the next 200 in VR ;)



    The game’s gamepad mapping is too complex to be replicated with vorpX’s gamepad to mouse/kb mapper. I spent half a day trying, trust me. Hence the according message that is shown when you launch vorpX.

    Since the game doesn’t allow gamepad and mouse input simultaneously and the gamepad mapper unfortunately is of no use either in this case, the only way to play it with head tracking is using a mouse. The only viable way for playing with a gamepad is playing in cinema/immersive screen mode without head tracking, which would let you use the gamepad natively.


    Thanks for the input. I know we can’t map everything and played around with options. I clearly see what you mean. Thankfully I found something that works out quite well for my playstyle.

    My concern is that it seems impossible to make a new profile. The official one seems hit or miss for me, for some reason, so I would love to try a different one. It’s about performance, not the controls :/

    I mean, it’s the first game where I can run it smooth on my screen, but even with no3D/immersive screen in vorpx it seems to skip a tonne of frames – and that’s then the freezes are not the problem. I don’t understand how a stable 100+ fps can drop to below 90 (so Oculus switches to 45 I think) if there is no 3D. Is that normal? Is even just immersive screen kinda “costly”?


    vorpX doesn’t just render the game, It also runs a second render thread in parallel that does its own rendering (most obvious in cinema mode, but in the other modes vorpX has to process the game image and send it to the headset as well, of course). That’s nothing you can change with a custom profile. Typically that costs about 10% of the original performance even without any 3D. Depending on the game and some other factors it might even be a bit more.

    There also comes another topic with this: since for normal developers it is not really possible to prioritize GPU rendering, doing two things in parallel on the GPU is fairly finnicky. If you encounter judder issues, there probably is too much going on to run both the game’s and vorpX’s rendering stable in parallel. There are several ways to deal with that:

    1. Reduce a game’s resolution.
    2. Dial down a game’s graphics options.
    3. Use vorpX’s FluidSync option (caps the game frame rate)
    4. Switch the ‘Headset Sync’ option to ‘Safe’ (leaves more GPU headroom)


    Much appreciated, happy to learn more about the how it all works. I guess this game will just have to run poorly on my rig then, no setting seems to help keep a stable fps. Going back and forth from 90 to 45 isn’t great and it’s immersion-breaking. Oh well!

    For everything else I play, Vorpx is the bomb! Keep up the great work :D

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!