Controller Mapping Uses NumPad Arrow Keys, Not Dedicated Keys. Breaks KOTOR

Homepage Forums Technical Support Controller Mapping Uses NumPad Arrow Keys, Not Dedicated Keys. Breaks KOTOR

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #216160

    I am trying to play Star Wars Knights of the Old Republic 1 and the issue is that vorpX does not map the d-pad (UP,DOWN,LEFT,RIGHT) buttons on the controller to the actual dedicated arrow keys on the keyboard, but rather to the numpad directional keys. In the vorpX controller mapping, the d-pad is listed as UP,DOWN,LEFT,RIGHT, however when these are pressed KOTOR registers it as 8,2,4,6 respectively. It doesn’t matter if num-lock is enabled or not, KOTOR requires the character codes for the dedicated keys (38,40,37,39), not the numpad key values (104,98,100,102).

    There is no way to bind these numpad keys to directional keys in KOTOR, it must use the dedicated arrow keys. I tried to modify the game .ini file and there is no option. I have even gone so far as to remap the numpad keys to the dedicated arrow keys using Windows PowerTools Keyboard Manager, however this also does not work. I have tried this with the Oculus controllers as well as an Xbox One controller, to no avail.

    This functionality is important in KOTOR because it is the only way to navigate menu items without using the joystick to move the mouse cursor which is very slow and error-prone as an input method. I would imagine that this functionality is also important for many other games for similar reasons.

    What is needed is a way to set the controller mapping to use the dedicated arrow key keycodes, instead of the numpad arrow key keycodes. Perhaps a toggle to use one vs the other?

    Please let me know if this fix/feature would be possible and if I can provide any other information about this problem. I would be very grateful for your assistance if so. Thank you.


    vorpX reads (and later sends) Windows virtual key codes for keys you assign in the gamepad mapper. For the arrow keys that would indeed be 37-40 decimal.

    Just a theory: maybe KOTOR directly evaluates hardware scan codes and somehow mangles the virtual key codes into something else. Really just a guess though. Maybe there is an external gamepad mapping app that can handle a (fairly weird) edge case like this, but for vorpX that would be a bit too much.


    Thanks for this tip. I downloaded AntiMicroX and mapped the controller with it and then disabled the controller in VorpX and everything works perfectly!

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!