Crysis (GOG version) Fov not applied

Home Forums Technical Support Crysis (GOG version) Fov not applied

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #188543
    madcap
    Participant

    The default profile is meant to set the fov through game settings, only that it doesn’t seem to be applied anywhere. The -20/+20 adjustments don’t alter anything either. Using the default settings from the profile I can Image Zoom to 0.60 which seems to be where the fov should be (there abouts), but the screen is too far away.

    I can’t see cl_fov anywhere in the vorpx modified ‘game.cfg’ file or anywhere else.

    #188544
    Ralf
    Keymaster

    Please make sure that vorpX has write access to the game’s install folder. If you installed the game under ‘C:Program Files’ you may have to run vorpX as admin for that. IIRC vorpX creates an autoexec.cfg in the game folder if everything works as it should.

    #188545
    madcap
    Participant

    I just found it in the autoexec.cfg file, but it doesn’t seem to be applied in game. The game isn’t on a system drive. Vorpx is currently running in admin mode.

    The fov in the cfg is: cl_fov = 96.016045

    Looking at console it seems to be displaying that setting, only that everything is distorting as it would if the fov was very low. The only way to get it near to how it should look is with Image Zoom.

    This is a GOG version. The OS hates my retail DVD version (obsolete securom I think), so I can’t test it.

    P.S. I tried with -devmode too, but it didn’t make a difference.

    #188550
    Ralf
    Keymaster

    That’s the correct value for Crysis. All I can really recommend is resetting the profile to its default values in the vorpX config app, although normally the FOV calculation considers every setting that may impact the FOV value.

    Also make sure not to use any mods that might potentially override the FOV. Not sure if such mods exist for Crysis, but if you use mods, try unmodded. Just in case.

    #188553
    madcap
    Participant

    I think there’s a problem with this GOG version. cl_fov just isn’t applied no matter what value I enter (even in console) in or out of vorpX (no visual change). Crysis Warhead (Steam version) does work with your crysis profile. Both shortcuts (x64, but I did also try x86) are being started with -dx9. I could assume a corrupted install, but I thought these commands were coded into the exe and the other commands seem to work.

    #188554
    Ralf
    Keymaster

    No such problem here with the GOG version. Had the game in my GOG account incidentally and checked that earlier. It uses the value that vorpX writes into the autoxec and I can also change the FOV from the ingame console. Would have been rather odd if that wasn’t the case.

    #188555
    madcap
    Participant

    I’ll give it a go later. There may have been files/entries left over when I aborted the retail install. I’ll clean registry too.

    #188556
    Ralf
    Keymaster

    I think I found the problem: you either have to start the game from the Galaxy app or launch Crysis.exe directly, both should work fine. Using the ‘Launch Crysis’ shortcut created by GOG however does show the symptoms you describe.

    Looks as if the autoexec isn’t executed when GOG’s CrysisLauncher.exe is used, which would also explain why the FOV can’t even be set from the console in that case. Without running the autoexec on start the console remains in restricted mode.

    You can either:

    Add ‘-dx9’ (without quotes) to the command line in Galaxy (More > Settings > Custom Settings) like suggested by vorpX and then start the game from Galaxy as usual.

    Or:

    Create a shortcut to ‘[Your Crysis Folder]\Bin32\Crysis.exe’ directly and add ‘-dx9’ (without quotes) to the target field.

    #188557
    madcap
    Participant

    I did a full uninstall and cleaned registry (I did find old entries, but mostly obsolete paths). Installed GOG version and it worked. Installed Tactical Expansion Mod v1.1 and it broke the FOV command. My bad, sorry. I just thought that mod changed some A.I and weapons and was basically my go to mod. I can’t see anything in the mod’s readme (it does have a known issues part) but no mention of this problem.

    #188558
    Ralf
    Keymaster

    First rule for any game: if you use mods, the very first thing to do in case of issues is trying without mods.

    Apart from that: I have absolutely no clue about Crysis modding, but if the game can handle custom autoexec files per mod, you might be able to use the values written into the autoexec by vorpX with your mod.

    Copying the autoexec.cfg created by vorpX to the mod’s base folder might be worth a shot. Just a guess though, I have no idea whether that actually does anything.

    #188559
    madcap
    Participant

    Copying the autoexec didn’t work. The DLL the mod uses must be breaking something. I posted the problem on modDB for the author to see, since this is a popular mod. If I find a solution I’ll post it here. Thanks for your time, Ralf.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.