Cyberpunk and quest2 – several questions

Homepage Forums Game Hints and Settings Cyberpunk and quest2 – several questions

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #204563
    PaulOblomov
    Participant

    First of all, hello everyone!

    I bought vorpx specifically for cyberpunk and I have a couple of questions, since searching the forum is just some kind of quest.

    1) i don’t understand the profile system at all and how it works. i create a new profile from an existing one, but i can’t select the .exe as it is supposedly already used by the default profile – how is that ?

    2) i want to edit a profile, i thought it was in the form of text – but nothing like that, binary. how and what to edit a profile with ? i couldn’t find any buttons or menus.

    3) already in the game, calling the vorpx menu I don’t understand how to save vorpx settings profile, because save and close does not save zoom, it is always reset. hence the question – are these the settings that vorpx saves as game profile settings ?

    4) reconstructing 3d through Z-channel looks good, but will full geo be implemented ?

    5) i have tr3960\3090\quest2 – i understand i need to create a custom resolution for quest2 for proper rendering ? i.e. just create 1832 x 1920 and it’s guaranteed to be what i need ? i just did, but with zoom = 0.6 the picture still looks different than say in alyx, black borders everywhere. i made fov = 90 and now need to solve the problem with zoom and resolutions

    6) the hud in the game stretches beyond the fov and I just can’t read anything there – is this again a question of proper resolution ? or can I scale the hud somehow ?

    7) in terms of rendering – the best quality 3D reconstruction is z adaptive or normal ? fov = 90 is also normal or i need higher ? because i see strange image distortions if fov > 90

    I just can't seem to trust myself
    So what chance does that leave, for anyone else?

    #204564
    Ralf
    Keymaster

    Please reset the profile to default in the config app and make sure that you didn’t accidentally disable automatic settings.

    There is nothing to adjust besides the resolution for a crisper image, and maybe the head tracking sensitivity in case you don’t use the game’s default mouse sensitivity. vorpX takes care of everything else, including FOV.

    Most importantly DO NOT touch the image zoom setting after resetting the profile to default. vorpX adjusts everything so that the game FOV fits the FOV of your headset, minor top/bottom borders (roughly 10%) are intentional for a decent balance between pixel density and performance.

    You may see a prompt requesting a game restart on first launch after vorpX has adjusted some settings. Make sure to do that whenever you see the prompt.

    Resolution wise select a 4:3 resolution (e.g. 1920×1440). That works well and leaves a bit of wiggle room on both sides for vorpX’s built in frame interpolation.

    The HUD is scalable. If you want to make it smaller than it is per default, you can do that on the ‘Image’ page of the vorpX menu.

    BTW: EdgePeek (mouse wheel click, right thumbstick click) is useful for checking the whole screen, e.g. in cutscennes or when you want to use menus

    BTW2: If you haven’t done so already, please check the ‘Essential Hints Guide’ in the vorpX help. It answers a bunch of questions you may have when you are new to vorpX.

    #204569
    PaulOblomov
    Participant

    The question of optimal settings is only a resolution ? Just the first time you start the game – 1600×1200, which looks terrible. But the HUD looks okay, more or less.

    Another question about the DLSS in the game. Can it be used ?

    More about zoom – if you lower it, the picture from a washed out turns into a normal picture. I can make it so that the zoom was minimal, but without the black borders ? It also needs to pick up the resolution or what?

    I just can't seem to trust myself
    So what chance does that leave, for anyone else?

    #204570
    Ralf
    Keymaster

    Just to reiterate: please reset the profile to default and afterwards DO NOT touch the image zoom setting for this game. vorpX adjusts everything related to that automatically. There is nothing to tweak besides what I wrote above: higher resolution for a crisper image and potentially head tracking sensitivity if you don’t use the default mouse sensitivity.

    Go as high as you can resolution wise. the higher, the better the image quality. Keep an eye on performance though (obviously). If you want you can also raise the sharpening a bit in the vorpX menu, but don’t overdo it.

    DLSS technically works in this case, but I would advise against it. Clearly the best upscaling technique available, but in the end it’s still just upscaling. If e.g. you set a 1600×1200 res and then enable DLSS, the image gets rendered at a much lower res, which is then upscaled to 1600×1200. IMO DLSS is good enough for (fake) 4K gaming on a monitor or TV, but with the image as close as in VR its shortcomings are just too obvious.

    BTW: For a fairly massive performance boost disable raytracing instead. Looks neat occasionally, but as in most games it’s not really worth the performance impact.

    #204571
    PaulOblomov
    Participant

    Of course I reset everything to default, that’s why I wonder why such a choice of default resolutions.

    I have completed cyberpunk with DLSS and raytrace with high fps at 2560. The quality is great, including DLSS in balanced mode (better than without it, since it removes AA jitter). Now I just want comparable quality, like in Alyx, which looks amazing in VR. So far, the default vorpx mode gives an awfully soapy picture. It makes me want to wipe my eyes. And information on how to maximize quality for the most technologically advanced game of recent times – I couldn’t find on the forum. That’s why there are so many questions from me.

    The auto mode does not give Alyx quality.

    The raytracing in cyberpunk looks awesome, and turning it off is wrong, imo.

    Another question – I read that you recommend turning on OpenXR mode for oculus in some cases – would it be better to turn it on for cyberpunk?

    I just can't seem to trust myself
    So what chance does that leave, for anyone else?

    #204572
    Ralf
    Keymaster

    Do you even read my replies? You have to raise the game’s resolution for a crisper image. Native games like Alyx at high settings typically render at resolutions of ~2000×2000. If you want comparable image clarity, you have to set a comparable game resolution.

    That will be difficult to achieve though at a VR compatible framerate for a game as demanding as CP2077, so you’ll have to make some compromises in the graphics details and/or resolution department (or buy a RTX3090 ;) ).

    DLSS: Again: works fine on a monitor or TV, but not so much in VR since your eyes are much closer to the imgae. DLSS actually renders at a much lower resolution than you have set and then upscales the image. That works quite well on a TV or monitor at 4K, but no so well with the fairly huge pixels in a VR headset at a resolution like 1600×1200 where the imperfections of the upscaling process are far more obvious.

    #204573
    PaulOblomov
    Participant

    I read everything very carefully, but it seemed like I was the only one doing it. I have a 3090, I wrote about it in the beginning :)

    And I’m asking about resolutions three posts in a row. Vorpx puts it at 1600×1200 – which is not enough for normal quality. Above 2560×1440 – the game does not allow to put, which forces to make a custom resolution in 2560×1920. And again, not the fact that it will be better. Probably there is a formula, according to which zoom will not blur the picture so much.

    The source of blur is the zoom parameter in vorpx. If it is below 0.6 the picture is clear. That is why I am asking about the dependence of picture sharpness on vorpx parameters. It may be obvious to you, but not to me. I am not a developer after all! And there’s not a word about it in the Help, and the profiles work according to some magic formula known to only you. Just default and everything works – not in this case.

    P.S. No words about OpenXR. And who reads worse ? :) BTW – in Alyx I did some screenshots and they are of 1440×1440… But I remember, FOV was far wider. Strange.

    I just can't seem to trust myself
    So what chance does that leave, for anyone else?

    #204574
    Ralf
    Keymaster

    When you lower the zoom, the image becomes crisper since you scale it down, i.e. the pixel density gets higher. However, like said three times now that is not what you want to do since as you noticed lowering the zoom obviously shrinks the image. Instead please raise the game’s resolution for a crisper image. That has the same effect on pixel density without shrinking the image. That costs FPS though.

    There isn’t really anything to suggest than that: for a crisper image you have to raise the game’s resolution. There is no way around that. You can’t run the game at 1600×1200 (plus DLSS, which means effectively rendering at someting like 800×600 and then upscaling to 1600×1200) while at the same time get an image fully filling the view of your headset with comparable sharpness to a native game that renders at more than 2000×2000 pixels internally.

    Sorry if I’m unable to explain this so that you can understand it better. It is so obvious that I just don’t know how to explain it any other way.

    TLDR: The only way to get a crisper image without shrinking it is raising the resolution the game runs with. There is nothing else that can be done to achieve what you want.

    #204575
    PaulOblomov
    Participant

    Love it. Thx!

    I thought zoom is something you’re using to adjust for FOV only, so I can force cyberpunk to render wider, reducing the need for zooming. Because zoom reads as zoom and not some crucial vorpx setting :)

    I think DLSS upscaling in a visually loseless manner, so you won’t see any f.e. bicubic artifacts or something like that. Curved line won’t be aliased and textures is crisper. Will experiment on this.

    P.S. Zoom=1.0 means full resolution rendering I see or it means what ?

    I just can't seem to trust myself
    So what chance does that leave, for anyone else?

    #204576
    Ralf
    Keymaster

    nVidia may tell you that DLSS is lossless, but it really isn’t. Just turn DLSS on/off in the game settings and check yourself. In a VR headset you can clearly see that the original image is rendered at a way lower res.

    DLSS tries to guess details that the rendered low res image doesn’t have based on the material the AI algorithm was trained with. That works well enough for faking 4K on a monitor or TV, and it’s way better than any ‘normal’ upscaling. But it isn’t perfect by any means. If personally you consider it good enough for VR, all good. Just be aware that it won’t match native rendering at the same resolution.

    #204579
    PaulOblomov
    Participant

    Well, do you see here something, that bothers you much ? Quality preset and original. I see better quality textures, as I said a bit earlier, but lower raytracing res and overall smoothness, like a lil bit of bloom applied. Is that that bad to you ?

    https://postimg.cc/gallery/v4Gs38p

    I just can't seem to trust myself
    So what chance does that leave, for anyone else?

    #204591
    Ralf
    Keymaster

    All good. I can just tell you what I saw in the headset with my own eyes while doing the CP2077 profile when I tried with DLSS, which was bad enough to think I should warn you that it doesn’t come close to rendering at native res.

    Best try yourself to turn it on/off. With your goal being the best possible image sharpness, I’d be a bit surprised if you’d consider DLSS the way to go, but all the better for you if you do. If it looks OK to you, no problem at all as far as I’m concerned.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!