Desktop Viewer Crashing on Launch

Homepage Forums Technical Support Desktop Viewer Crashing on Launch

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #208723

    Problem in the subject/title:
    Trying to get Desktop Viewer to Work. Long time user, i create the star citizen VR tutorials using this program, and as of a few months ago Star Citizen switched over to Easy Anti Cheat.

    I got a work around using Reshade (w/o depth injectors) along with opentrack and Virtual Desktop in side by side mode, but im told I can basically achieve the same thing with the VorpX desktop viewer.

    i have never used this app before, and everytime I try to launch it, all it does it crash back to the Index SteamVR Home Screen after I run it. I cant get it to work at all, and have tried everything from updating windows, to cutting down to 1 monitor instead of 3.

    Nothing seems to be working and was trying to figure out why it wont launch at all.

    I use a full prebuilt AMD rig (6800xt and 5900x) with windows 10 that i bought from digital storm along with a valve index/steamvr that im currently running on.

    Needing help to just get it to launch in any way/shape/form.


    Did you make sure you ‘Paused the watcher first’? If you don’t, VorpX will still try and hook over-riding desktop viewer.

    Also, why are you bothering with Reshade? Without the depth injection? At best all you’re doing is splitting the image in two, then stitching it back together again as a 2D image – with worst visuals. Just stick with desktop viewer.

    I’ve had it running with desktop viewer and opentrack for head tracking.

    I think Ralf mention in another post he might get the Trackir emelement working in desktop viewer too – that would be a big help here.


    @ chachi123

    Two things I can think of:

    If you have any tools running that hook into the graphics pipleline (GPU tools, recording tools, overlays), try without. Unlikely that those would get in the way with the desktop viewer, but who knows.

    If your system by any chance has multiple GPUs, the desktop would have to run on the same GPU that your headset is connected to.

    If you can’t solve the issue, I’d like to take a peek at your log files and system config. You can create a trouble shoot data archive in the config app. Please send that to support at vorpx com. With some luck maybe I can spot something unusual.


    So i tried to pause the watcher, thinking that was my problem and that I’m an idiot. However, that didnt solve the issue, and it crashed back to SteamVR Home right after it launched again. So that didnt resolve the issue.

    I have check for extra overlays and only have steam running in the background.

    I just hooked up a 2nd GPU but havent installed a driver, and desktop/vr is hooked up to my main GPU only, AND the problem persisted when it was only a single GPU.

    I tried to turn off everything I can think of, and im out of ideas.

    As for the zip of the logfile, here is the link:

    I tried to submit a help request formally instead of making a forum post, but chrome wouldnt let it send or go thru, even after I turned off my adblockers, so if there is another way you want me to send or link it, that would be a ton of help instead of me having to figure out why the website wont let me post a support request. For now, I just threw it on my google drive.

    Thanks for taking a look


    Forgot to reply to your actual post earlier, here is the link to the logfile:

    Cant submit actual help request cuz chrome wont let the next page load. Tried turning off adblockers, still wont work.


    Unfortunately the links don’t seem to be public. I can’t access them.

    Probably best to send the archive as a simple e-mail attachment to support at vorpx com.


    Got the logfile now. Thanks.

    There is definitely something odd going on, an exception at a point I never have seen before. Unfortunately I don’t really have a clear idea what may cause it.

    It would be great if you could briefly check whether removing the nVidia GPU from your PC helps. Nothing in the logfile indicates directly that might be the problem, but since it’s the only thing that looks unusual in your system config, there is at least a certain chance that the issue is related to having both a Radeon and an nVidia GPU in the machine.

    Also please try whether uninstalling Virtual Desktop helps. That might definitely get in the way potentially.

    There are also a whole bunch of other tools and utilities running in the background. Just to make sure none of those causes some weird conflict, it’s worth a shot to try without any of these tools running. E.g. the Razer stuff, the mouse utility, Discord. For testing purposes exit as much as possible that you have running in the background.


    I also cannot launch the desktop viewer. The window is open but all is black and the headset doesn’t show it.
    I emailed you my logs


    @ drowhunter

    You shouldn’t actually see a window, only an icon in the taskbar. Just in case: the desktop viewer does not work with the ‘Generic VR Headset’ selected in the vorpX config app. It only works with ‘OpenXR’, ‘SteamVR’, ‘Oculus’.


    Ok that explains why I couldn’t pull up a window, but I have steamVR selected and I can see the steamVR background and ui in the headset. but when i launch the desktop viewer nothing happens. I know this was working a few weeks ago.


    I have a similar problem in which I noticed that when I am watching a video and suddenly a cpu spike comes in, that’s when vorpx desktop quits silently and steam vr opens up. I tried closing every other program in the task bar to make sure screen overlays are not present.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!