Deus Ex: Human Revolution

Homepage Forums Game Hints and Settings Deus Ex: Human Revolution

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #10981

    Hello! I have some interesting issues with Deus Ex.

    Issue: While I play, the keyboard doesn’t “lock” to the game. Every time I press a key… w,a,s,d, etc… my system dings. It’s like it’s sending input to the OS, and the OS knows it can’t accept the input, so it plays that warning ding to alert me.

    The game plays under the following config:
    DX9, Geometry
    Use System Settings for VorpX Screen settings.
    Primary Monitor, 1920×1080
    Duplicate screen for Rift.

    Deus Ex runs at either 1280×800, or 1920×1080.

    Additional issues… the guns are rendered in 2D, and at a different “plane of focus” than the game scene, if that makes sense. Basically aiming with the gun doesn’t work, because if I’m focusing on the target I see 2 gun sights in the foreground. If I’m focusing on the gun, I see 2 targets in the background.


    BTW, I just tested this… In DX11, “Normal” rendering, the game works as I would expect, but the guns aren’t rendered quite right. it’s like they’re made of several layers of sprites at different depths.


    Hi Trust,

    If you don’t mind, please post further support questions in the general forum. This one was meant for tips and tricks and such. Thanks.

    To answer your question:

    The guns are indeed 2D, that’s nothing that vorpX can do anything about, unfortunately.

    The ‘Ding’-issue happens here too in DX9, DX11 works, but has only Z-Buffer 3D yet. Must have been introduced lately. Funny bug, I’ll call it the “Hector Salamanca Bug”. Not sure what might cause it, but it will be investigated.

    Aled B

    I’ll call it the “Hector Salamanca Bug”.

    Well played! ;)


    DX11, Win7 x64, game from Steam: no stereo
    there’s a pic
    (when i press prt scr it makes a screenshot of desktop but not game)

    I’ve tried different settings – useless

    in DX9 mode stereo is working, but with strange lines, invisible cursor and vorpX hotkeys doesn’t work


    In DX11 the game is Z-Buffer 3D only currently, which has less Stereo 3D but is twice as fast.

    The DX9 screenshot is not from vorpX, the game should show the circular vignettes and the vorpX logo when it runs with vorpX. Most likely you have another stereo driver running that interferes with vorpX. Also please check for any d3d9.dll in the game’s directory and remove it.

    Hope that helps.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!