Direct VR and source engine based games

Homepage Forums General vorpX Discussion Direct VR and source engine based games

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #125763

    first of all kudos to Ralf for bringing direct VR, it’s a real game changer for me, much closer to native vr support.
    Although, I am experiencing an issue with a few source engine based games.
    With direct vr enabled, there are some glitches every 2/3 seconds, like flashes in which some elements (or the entire world) disappear and suddenly reappear. The problem seems to get worse I areas with a lot of details.
    I am experiencing this with Portal 1, Dear Esther (custom profile copied from portal 2 to enable direct vr) and Infra (profile copied from portal 2 as well).
    Everything works well except from this issue.
    Could it just be that direct vr requires more power and my pc is not powerful enough?
    I have an i5 skylake, 16 GB, GeForce 970, windows 10 pro and oculus rift dk2.
    I never had stuttering on native vr games or vorpx without direct vr so it would seem strange to me.
    Thank you for your help!


    I’ve been working on Direct VR quite heavily over the last few weeks. Among other things major improvements incoming for Source engine games shortly (all will have positional Direct VR for basic roomscale with the next vorpX). There will also be changes in regard to how the values are applied for Source games. I can’t promise whether that will solve all potential issues, but it should improve things.

    One thing that is important in Source games is to choose a 4:3 resolution for the games. Otherwise the chance of flickering is a lot higher. So if you aren’t using a 4:3 res that’s one thing you should definitely do.

    In some games (including Source engine games) Direct VR is indeed more demanding CPU wise. An i7 is better equipped for that due to Hyper Threading, but an i5 is perfectly fine normally for Source games. If available you could try to disable multi-core rendering in the game’s options, which may make it easier for the CPU to schedule tasks. Some of them have that option (e.g. Portal 2).

    BTW: If possible anytime soon, update to a GTX 1070. Makes a huge difference for vorpX in general compared to a 970.


    I don’t have any mods (I deleted everything minus saves… including ini files… reinstalled… started… quit… Ran Game Settings Optimizer for fallout 4. Tried again.

    This time, I started from scratch (previously I was running a new game that was just out of the vault… I started over).

    I got the first two working, but not the last one (positional I believe). Ran through the vault. Got outside and tried again (still only the first two worked). Saved… Loaded… and now only the first two are working again :(

    Also, I’m still only getting the Aspect Ratio when launching for 16:9 in the graphic adapter settings. I’m guessing this is part of the problem. The dropdown itself is grayed out. I also don’t have an option to select all available resolutions like in Skyrim.

    If I start in windowed mode, I get 16:10 also, but still no 4:3.

    Should I be modifying the ini file for the resolution and trying again?



    This should have been an answer to your Fallout 4 thread I guess? The resolution is of no concern for Direct VR. If you play with Geometry 3D you have the normal positional tracking available. So with rotation and FOV you are perfectly fine. Those are the most important ones. Positional Direct VR is the icing on the cake.

    There always is a certain chance of failure, for more details on that please check the hint text that is shown during each scan. The next vorpX version will have changes regarding FO4 Direct VR too, with some luck that will help with your position issue.


    Many thanks for the advice! All three games were indeed set to 16:9, and switching to 4:3 improved things a lot.
    Now there is still a little bit of flickering here and there, but much less annoying.. almost perfect! :-)


    btw, one more note. I did change the keys. I know that you go into menu mode for some of the directvr stuff. Not sure if that is causing a problem.

    And I can’t see the pipboy or pick locks currently. I did change to 4:3 manually and it helps the look/feel, but it doesn’t help the directvr.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!