Direct VR Scan fails in all games?

Homepage Forums Technical Support Direct VR Scan fails in all games?

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #200757

    Direct VR scan fails in every game I have since I upgraded my hardware to an i7 107000k with a new MSI EDGE WIFI 6 motherboard and 32GBs of RAM. Granted, I’m still stuck with my GX 1080 FTW. Could that be the issue?


    i also have my direct vr scan fails sometimes.

    when it “fails” i can briefly see the steamVr launching rectangle application on and off while directVr is doing its scanning, like a micro hang thing or something.

    i know for sure that direct VR was working perfectly fine like 1 year ago but sadly in my case not anymore.

    atm my setup is

    3090 FE
    32gb ddr4 3600
    w10 20h2
    all drivers/bios uptodate
    SSDs sata
    hx 1200w
    valve index (and issue was also on my htc vive)
    base stations 1.0

    my previous hardware

    gtx 1080
    16gb ddr4 3000
    w10 1904 (and previous versions)


    The DirectVR scanner scans through a game’s RAM, the GPU is of no concern. If you experience issues with that in every game you try, your very first suspect should be your antivirus program, which may interfere with or even actively prevent what the scanner does. The usual recommendation here: if you happen to use anything else than Windows Defender, get rid of it as fast as you can. There is no need for invasive third party AV on Windows 10. Windows Defender is more than good enough for several years now. It kicks in automatically when you remove third party AV.

    Also makes sense to avoid many other programs running in the backround as that can affect how Windows organizes its memory pool. In a few games the scanner expects a certain memory layout, which might get messed up the longer your PC is running and the more stuff you have open in the background.

    In the same regard a full reboot (not switching off/on, which just takes a system snapshot to speed up the start) is always worth a shot. Choose “Restart” in the Windows start menu to ensure a full reboot.

    However, apart from all said above the message shown during each scan still isn’t shown just for fun: since scanning through a game’s memory for a handful of addresses is a rather complex matter, there always is a chance of failure and there is no guarantee that the scanner will always work. It usually should though if nothing gets in the way.


    In Task Manager, I Ended Task on Windows Defender, some Nvidia stuff, and a Logitec app for my mouse. The rest was Windows 10 system, Steam, or vorpx stuff. But FOV scan still fails for all my games.

    I did try to fix Bioshock Infinite and Halo 4 manually, but (and I know I probably sound dumb), I can’t find 3D FOV Enhancement in the in game vorpx menu. Am I crazy, or is the setting missing in these games in geometry mode? Or do I have to turn off Direct VR memory mode for it to appear?

    P.S. Three weeks ago, I was able to do it all manually for Resident Evil 3 2020, but it may have been partly the First Person Mod.


    In Bioshock Infinite per default the FOV is handled via an .ini edit, not with the memory scanner. Please reset the profile to default in the config app and afterwards make sure to follow the hint shown in the top left corner of the game window regarding setting the FOV slider in the game’s options to max. Without that the .ini edit DirectVR does has no effect.

    Halo 4 doesn’t have an official vorpX profile. If there happens to be a user profile with supposed memory scanner functionality it’s unlikely to fully work, if at all. The scanner configuration is fairly game specific. Also scanner profiles don’t always include FOV. You can see what the scanner does and what it doesn’t in a game on the DirectVR page of the vorpX menu.

    The G3D FOV Enhancement option can be found under “More 3D Settings” on the main page of the vorpX menu. Be aware though that in most newer games it causes too many visual glitches to be of much use.

    BTW: A general way how to handle FullVR for games without automatic FOV adjustment is explained in the “1-2-3 Game Setup” guide in the vorpX help. The method described there isn’t always 100% perfect, but it always works. Additional information regarding FOV can be found in the “Essential Hints” guide in the help.


    Thanks! I’ll reset the Bioshock profile to default and try again.

    Unfortunately for me, reading the text in the top left corner is almost impossible with my eye sight. In real life I can physically move closer or magnify the screen for any small text. But with most VR interfaces, the UI stays stationary no matter where you are. I’m predicting this will change once programmer’s eye sight begins to go with age. Until then, I have to guess what most text says.


    setting the FOV slider in the game’s options to max.

    Maybe this is the issue. The hint for Bioshock Infinite is telling me to set the FOV to center, not max. Which one should I do?


    setting the FOV slider in the game’s options to max.

    Maybe this is the issue. The hint for Bioshock Infinite is telling me to set the FOV to center, not max. Which one should I do?



    Anyone stuck like me, here’s a quick dummy’s guide to fix Direct VR scan…

    1. Open Vorpx Config, select Restore Game Settings, select the game, and click restore pre-vorpx settings.

    2. Select Cloud profiles and import the vorpx profile for the game.

    3. Start the game in vorpx and follow the instructions in the top left corner of the screen. Probably says to change game FOV to max. Do that, save and quit, then restart game.

    4. Once in the actual game, run Direct VR scan.

    5. If image is still warped go to Image Zoom in the in game vorpx settings and tweak until image is normal.

    Thanks again, Ralf!

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!