Dirt 3 hook not working – fresh install (Dirt 2 is woking though)…any ideas?

Homepage Forums General vorpX Discussion Dirt 3 hook not working – fresh install (Dirt 2 is woking though)…any ideas?

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #17961

    I’ve been messing with vorpx since yesterday. Had a REALLY hard time trying to figure out how it worked. Could get Far Cry 3 to display the vorpx screens and stereoscopy but only on my monitor…Dirt 3 wasn’t doing anything at all.

    Only when i tried DIRT2 i managed to get it working. I know now you really have to have your rift setup as the primary monitor BUT you can alt-tab and put your monitor back as primary once the game is launched.

    I used to race a lot with tridef on both dirt2 and 3 so i know how important it is to find the sweetspot with seperation, the fov etc…

    All in all vorpx seemed to be as good as tridef in dirt 2 once i got it working….

    ANYWAY…DIRT 3 isnt’ doing anything. The hook isn’t working. Does anybody have ANY idea as to what might be going wrong?


    For most games you don’t have to set the DK2 as primary monitor. If you haven’t done so already, please check the DK2 setup guide in the documentation. It explains how to setup vorpX with the DK2 as secondary monitor. Normally ~90% of games should work this way.

    Dirt3: One thing you could try is switching from DX9 to DX11 or vice versa. Normally both should hook, but maybe one works better for you. (DX9 is preferred due to Geometry 3D support)

    For Dirt 3 there is a Game Optimizer entry in the vorpX config app that allows you to switch to DX9 automatically.

    in case the Game Optimizer fails for some reason, you can also do this manually:

    1. Open [My Documents]\My Games\Dirt3\hardwaresettings\hardware_settings_config.xml with a text editor
    2. Search for forcedx9=”false”
    3. Change the line to forcedx9=”true”
    4. Save the file


    Hi Ralf, the xml already showed it being forced to directx9…which might have been because of vorpx in the first place?

    Anyway…the weird thing is that i found out yesterday it DOES WORK in directx11 but still no go in directx9???

    I have no interest in z buffer 3d so i really want it to work in geometry

    Do you have any idea how this could be?

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!