Display corruption/artifacts in VorpX games after Win 10 update

Homepage Forums General vorpX Discussion Display corruption/artifacts in VorpX games after Win 10 update

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #111661

    So I was playing Alien: Isolation on my one month old CV1. Everything worked just fine after setting FOV, VorpX, nvidia DSR for 2k and 4k resolutions, playing for more than 2 weeks no issues, all flawless.
    Last night Windows 10 decides to upgrade to Win 10 anniversary edition and this happens: https://youtu.be/ZUG8CiaYbSI

    Artifacts appear across the entire display in VorpX games as seen in the video I recorded with my phone through the right CV1 lens. Sometimes they take a while to appear, sometimes on 4k DSR resolution they are present from the intro. This never happened before the update and I don’t use overclock settings (where this kind of artifacts are specific for unstable overclocks). The only way to get rid of this issue is to switch to another resolution and after 15-20 minutes it starts again.

    Same thing happens in other games like Stalker: Call of Pripyat (Misery mod) which I have finished on CV1 before Alien: Isolation with no issues. Didn’t see the issue in Half Life 2 on VorpX. Also, it doesn’t reproduce on native titles like Elite: Dangerous, Oculus Home demos etc or on 2D monitor (checked in Alien: Isolation with 1080p and 4k DSR resolution, flawless)…this happens exclusivelly in VorpX titles.

    Any suggestion Ralf ? Or someone who encountered this ? Is this something that can be fixed in a future VorpX update or is there any workaround ? Cause it’s extremely annoying, especially on VR horror games and so far changing the resolution is the only temporarily fix for 20 minutes, but when it occurs again it is so immersion breaking.

    I’m on i7 6700k CPU, 16GB DDR4 and nVidia GTX 1070. Please help, the majority of games I’m playing on CV1 are VorpX based, Microsoft screwed me bad this time. Anyone else experienced this since the damn update ?


    Try different nVidia driver versions. I can’t remember which one, but there is at least one recent driver release that introduced such artifacts occasionally on HMDs.


    Ok Ralf, thanks. I had 372.70 when Win 10 updated and started to manifest the issue…I updated to 372.90 and the issue was still there. I’ll try a clean install, not the one through GeForce experience or older ones, I found a user here on the forums that had the same issue with 372.54 and 372.70 and did not have it with an older one. If it’s the driver it would be kind of sad since they promoted new VR features for most of the iterations I saw lately.


    Indeed nVidia drivers caused the issue but it didn’t manifest until the Windows update…wierd.

    I installed all the drivers in 372 series (372.54, 372.70, 372.90) and none of them worked, all gave me the artifacts after a few minutes or instantly on 4k DSR resolution. As the other user who had this issue on the forum, the problem was gone in 368.81, everything performed just fine. Thanks Ralf and Thoraz for the info !

    I wonder if nVidia is aware of this issue affecting their drivers, considering they promote their game ready driver like this: “Game Ready Drivers provide the best possible gaming experience for all major new releases, including Virtual Reality games”

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!