Elder Scrolls Online not hooking

Homepage Forums Technical Support Elder Scrolls Online not hooking

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #90736

    Anyone here have luck with Elder Scrolls Online? ESO is the game I played most with vorpx and now it doesn’t seem to work for me post vorpx .9. Its like it tries to hook but the video never makes it to the HMD. The mouse / keyboard are captured though. I had minor luck through virtual desktop mode but F that mess, I was playing with full geometry 3d before the udpate… I was just curious to know if anyone has had success with playing ESO since the update or if they too were having problems getting the game to hook?


    hey slonaker,
    i´ve tried to play eso with dk2, too.
    It never worked for me but i think its because i tried it just with .9 only… i hope there will be a fix soon or maybe a step by step guide to solve this.


    Same thing, here. ESO is weird about its fullscreen/windowed options — if I run the game “fullscreen” (not borderless fullscreen window) with its resolution set to 1920×1080 but my desktop resolution is 2560×1600, the 3d elements of the game indeed render at 1920×1080, but 2d elements — the entire UI — still render at 2560×1600. Very annoying and I wish they’d give us “true” fullscreen.

    So I figured maybe that was VorpX’s problem. So I turned my desktop resolution down to 1920×1080, but still nothing. nVidia’s new drivers have this little “share” overlay that pops up when you start a game, so I went in and disabled that, which accomplished precisely nothing. I tried tabbing in and out, which worked in one of the third-party injection drivers, once upon a time (I think it was Tridef) — nothing. Alt+Enter to toggle between fullscreen/windowed mode — nothing.

    Long story short, I have no bloody idea what to do and this whole “direct driver” business is a huge pain in the ass. I only blame Oculus for that.


    Direct driver business is what Oculus needs. It’s the extended mode that Oculus needs to lose, hence 0.7 and above.

    My vorpx wasn’t detecting Battlefield 4 or GTA V. Turns out my comodo internet security was killing the vorpx control process needed for 64 bit games. The vorpx control (32) was unaffected. The only way to get the 64 bit vorpx control back was to completely uninstall comodo. Vorpx now works uninhibited.

    Switched to a different free firewall: Privatefirewall 0.7

    I use runtime 0.7 with vorpx .9


    ESO does indeed not hook with vorpX 0.9.

    The issue is caused by ESO initializing its renderer in a slightly unusual way combined with a new feature in vorpX 0.9 that is meant to prevent unwanted hooking.

    Will be resolved in the next vorpX version (no date set yet).


    Oh, I know it’s necessary. The Rift can’t be simply treated like another monitor, for the sake of ease in launching games, transitioning out, managing windows, et cetera and so forth. Just saying the implementation is proving to be rocky. I know we’re using dev kits. Just venting, man. Commiserating.

    I’m using runtime 0.8 with VorpX 0.9. Rolling the runtime back to 0.7 was going to be my next step, this morning, but Ralf’s input seems to indicate that won’t make a different. Cheers to all.


    Well thanks for verifying Ralf. Just a heads up, World of Warcraft seems to do the same thing. :/ Even though WoW is essentially unplayable on rift imho, it was cool to try out occasionally. I have gta v,bioshock 1/2/Infinite and halflife 2… all I want is ESO! ugh! lol


    How about ffxiv? Do we have a snowballs chance in hell of seeing this title any time?

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!