F1 2019 working with in game head tracking

Homepage Forums Game Hints and Settings F1 2019 working with in game head tracking

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #186607


    I had been annoyed with the YouTube videos claiming to show how to run the “F1 2019” game in VR using Vorpx and Opentrack, having tried to follow their instructions I realised where they had gone wrong.

    Sorry if someone has already shown how to do this correctly but I couldn’t find instructions anywhere that actually worked correctly.

    The following method works well for me (unlike the various click-bate YouTube videos) this results in a pretty good experience. The YouTuber versions end up with you looking either looking at a great big VR cinema type screen or where the head tracking either doesn’t work or is terrible.

    This method works (its not perfect but it is comfortable and very playable):

    From VorpX config go to the “Cloud Profile” tab, search for “F1 2019” and download the cloud file for the game, at the time of writing there is only one file available “F1 2019 BY DONPRIMILLO”- Many thanks to whomever created this file.
    Next go to the vorpx config “General tab” and uncheck “Head tracking” and “head tracking roll”
    Save and Close Vorpx config but leave the main vorpx program running

    Download “OpenTrack” from Github – https://github.com/opentrack/opentrack/releases
    Run the “opentrack” .exe program (please note that these instruction are for the Valve Index and steamVR but I expect they will work for anyone using SteamVR).
    From the main screen choose the following settings:
    Input – select “Valve SteamVR”
    Output – select “Freetrack 2.0 Enhanced”
    Filter – Delete the filter option (no selection needed)
    Click on the options button:
    “Shortcuts” tab – select “Bind recenter” and choose a shortcut key, I used “Z” but whatever works for you
    “Output” tab – select “Pitch” and choose Pitch, Select “Yaw” and choose yaw, select “roll” and choose roll.
    Click “OK”
    Now close the Opentrack program
    You have to close the opentrack software or (at least in my case) SteamVR will not launch if opentrack is running.

    Launch Steam
    Got to the “Library” tab and launch the “F1 2019” game, it is important to select the DirectX 11 version only (this should flash up in a windows), note I don’t think VorpX works with DX12.

    VorpX should flash up a dialogue window and also should launch SteamVR.
    Once Vorpx, SteamVR and the “F1 2019” game have all launch correctly and you can see the “F1 2019” game running in the HMD (Valve Index in m case) you press the windows key on your keyboard and then navigate to and launch the “Opentrack” software.

    Click on the the “Start” button and return to the “F1 2019” Game by click on the icon in the bottom of the screen to make the game the focus.

    F1 2019 game:
    You now need to change the game settings – Within the setting section you need to set the following:
    Game options
    Camera options:
    Camera select – Cockpit
    Field of view – 1.0 (maximum available)
    Camera shake – 0
    Camera movement – 0
    Look to apex – 0
    Head tracking with TrackIR – “On” (this is the most important part as this allows the game to see the opentrack output – all of the YouTube videos go wrong with this step)
    Save these setting

    Put on your HMD
    Press the “Delete” key on the keyboard which should launch the VorpX menu within the HMD screen and choose the following settings:
    Got to “Main Setting” tab
    Play style – “Full VR mode”
    3D Reconstruction – “Z-adaptive”
    Head tracking sensativity – 1.50
    Save and exit the Vorpx VR menu

    You are you finished, start a race and hopefully this method will work as well for you as it does for me.

    I have noticed that playing around with the resolution can make a big difference so you might want to find what works best for you.

    Lots of steps but I hope this is helpful to someone…..





    as good as this guide is, as sad it is, that the mentionend profile “F1 2019 BY DONPRIMILLO” has vanished from the online profiles (whyever..).

    There are several youtube videos promoting it, but it seems to be gone.
    Could you re-upload the profile?


    Thanks for the guide, @Bacon2002.

    I do not have F1 2019 though I have a question regarding head tracking via Opentrack.

    Besides rotation, how is the positional (moving to the sides, up/down and forward/backwards) tracking working for you? Did you managed to get it working 1:1?

    Thanks, Milan


    I updated a new shared profile within vorpx, you should be able to find the new version of the profile now called “F1 2019 DPHv2”
    Let me know how you get on.


    I though this game was G3D? why aren’t you using Vorpx head tracking?


    I have got this working quite well aside from the resolution. Head tracking and all that works great. How do i go about improving the res in the HMD? It seems like it is about half of what i get in other games. If i can improve the headset resolution this will be fantastic!

    Also, now that VORPX has native f1 2019 support it wont let me enable your profile or delete the built in one so i can enable yours.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!