Fallout 3 – Silky smooth gameplay

Homepage Forums Game Hints and Settings Fallout 3 – Silky smooth gameplay

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #190073

    I finally had time to sit down and really tackle getting Fallout 3 to work properly with vorpX. For those who don’t know, titles based on that engine (so at least FNV and Skyrim, plus probably others I don’t know about) had all kinds of fundamental game-engine-based frame-rate and stuttering issues, even on vastly overpowered rigs. So I thought I would put my finding here in case other vorpX users want to get it running well.

    For reference, my rig is a Quad-core i7 overclocked (and liquid cooled) to 4.4 ghz, 16GB ram, all SSD storage, and an RTX 2080 Super card. So pretty capable, but definitely not top-end by VR standards. This is running a Pimax 5K+ HMD, so I have to run relatively high resolutions to really make use of the Pimax.

    I’m only shooting for acceptable lounge-mode performance here with – not full VR. If you want to achieve true 90fps you might have problems anyway, as the FO3 engine will experience significant issues when pushed above 60fps. So everything here will probably apply to you but you’ll likely need to to use one of the various fake-frame methods (brainwarp, async, fluid sync etc.)

    I’m not going to give step-by-step instructions here, because if you need a true step-by-step for any portion you can easily find it already written-up online many times over. I’m also not going to cover what FOV settings to use etc., because those are all going to depend on your HMD and personal preferences anyway.

    Here are the key things you will need to do to make FO3 run smoothly:

    1) Disable Vsync in your .ini files. Don’t rely on the launcher option to do this, it doesn’t actually work. You have to set the iPresentInterval value to 0 manually in the ini files.
    2) Install FOSE: https://fose.silverlock.org
    3) Install the Fallout 3 Stutter Remover: https://www.nexusmods.com/fallout3/mods/8886?tab=description
    4) Edit the stutter remover .ini file (sr_Fallout_Stutter_Remover.ini file in the Data\FOSE\plugins folder) and set the maximum fps to 60 (you can use other settings if you wish, that one works very well for me. If you rarely get 60fps you might want to limit your fps to a value that works better for you. Even clear down at 30fps the game isn’t too bad in Lounge mode).
    4b) If you are using Windows 10 also edit the stutter remover .ini file with these necessary Win10 fixes:

    turn off the features in these 2 lines:
    bHookCriticalSections = 1
    bHookLightCriticalSections = 1
    by changing the 1s to 0s:
    bHookCriticalSections = 0
    bHookLightCriticalSections = 0

    5) Disable any driver level fake-frame features (brainwarp, motion smoothing, etc.)
    5) Launch your game using the FOSE launcher app.
    6) Disable all vorpX fake-frame features (this isn’t technically necessary, but to my eyes they just make things look uneven. If you absolutely have to get 90fps I suggest trying the Fluid Sync mode and limiting the fps to 45 in the stutter remover .ini file. That’ll give you a game engine running at a solid 45fps, doubled to 90. To my eyes that looked like the best of the fake frame methods in FO3).

    Using those settings I’ve got absolutely silky-smooth framerates with zero stuttering at very high resolutions (2560×1440+) and quality maxed across the board for FO3 (plus many high-rez texture mods and ini tweaked to ugrids=7), even with all of my “VR Quality” settings set to 100%.

    Note that there appears to be some sort of a bug in the Fluid Sync setting – after an area transition and at other times it will still lock my FPS to 45 for a period of time. You can either toggle Fluid Sync on and off again, or just wait a while, and in a short while (usually less than a minute) Fluid Sync will disable itself again and your FPS will shoot back up to whatever your maximum value is. (P.S. Would *love* to see this Fluid Sync issue fixed!)

    Hope that helps a few people!

    Things I haven’t been able to fix: Incorrect focal-depth for PipBoy display and terminal screens. (If anyone knows how to fix this PLEASE LET ME KNOW!) This causes a double-vision effect for those items. (P.S. Would also *love* to see this fixed!)

    Here is a “solution” of sorts:

    1) Bring up the vorpX in-game menu and set a dominant eye.
    2) Close your non-dominant eye when using the PipBoy or Terminals.


    Thank you very much for the breakdown, ive intended to give new vegas a shot in vorpx, currently working on skyrim vr right now, but this may really help me out when i jump to new vegas, thank you for taking the time to give a write up!


    I hope it helps. As far as I can remember all of the same basic fixes work for FNV and FO3 (although, you will have to download the proper versions of the Script Extender and Stutter Remover etc.)


    I hope it helps. As far as I can remember all of the same basic fixes work for FNV and FO3 (although, you will have to download the proper versions of the Script Extender and Stutter Remover etc.)

    ya, i figured this wouldnt be that hard to extrapolate over to new vegas. if it doesnt, all good – i still need to give fallout 3 a full vr playthru anyhow, played it back in the day but not all modded out and in vorpx yet, so i got a whole game just sitting there, just was gonna do new vegas first cause never finished it – so either way, ill be taking your advice for an eventual playthru lol..

    if any wicked crazy mods like motion tracked controllers comes out in these games like doom 3 bfg edition got – please point them out lol


    Test, this is a test only. Looks like the forum has a bug in its software. Please ignore this posting.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!