FSX and vorpX 0.8.1

Homepage Forums General vorpX Discussion FSX and vorpX 0.8.1

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #81062

    Hi folks… I am just catching up ahead of updating to 0.8.1 and planning to try FSX on my Oculus Rift DK2. The machine has FSX on Steam rather than my boxed version of FSX. I see some of the issues folks have had with Steam and Steam overlay.

    Do we now expect Vorp 0.8.1 as updated to work with Steam games and FSX in particular? It would be good to know before I start to set this up.


    Almost all games we are working with are Steam games.

    The only important thing for the Steam FSX version is to start vorpX with admin rights (can be configured in the vorpX config app). Normally this should be avoided, but Steam for some reason starts FSX with admin rights, so vorpX also needs admin rights in this case to be able to hook into the program.


    Thanks Ralf… I am now set with beta, followed the DK2 configuration (for Windows 8.1 so using extended desktop landscape flipped orientation as usual) and set VorpX to run as admin. Launched FSX and I am trying various windows + arrow key things to shift the display onto the Rift. Also tried running FSX in full screen mode as well as windowed, and windowed but maximized. After flight select/vehicle screen, and launch I can move the display over to the Rift but is not yet displaying full screen or in 3D. Best I managed was to see the two barrel Rift view screens on flat primary monitor with some combination of settings.. but could not shift it over to Rift.

    I also tried various combinations including having the Rift as a primary display… that is a fun experience trying to get the task bar back and losing the mouse :-)

    I wonder if any Flight Simulator X with DK2 user out there can give me the detailed recipe for this specific game?


    Works here with the “convenient” setup from the DK2 Setup Guide (DK2 as secondary and vorpX set to “Show on Rift DK2”). With DX9 1920×1080 fullscreen it launches on the Rift. FSX does a few odd things technically, loading bars for example are shown on the monitor for me, but the actual flight window opens on the Rift this way.

    If you use the Rift as primary, you have to set vorpX to “Use system settings” display wise. Just a guess, but maybe that’s your issue.

    IIRC you can also select the output device in the FSX graphics options, but I may be mistaken in this regard.

    For Geometry 3D DX9 is mandatory, DX10 is 2D only.


    Thanks again Ralf… sorry to misuse this “steam games crash” thread for an FSX question. Not there yet, but I will continue to experiment. I am using Windows 8.1 and Nvidia GTX 680 by the way. I am now set up directly as you suggested rather than trying the various other modes I was experimenting with. Setting now is:

    DK2 as extended desktop and set as screen 2
    DK2 set to landscape flipped so its the right orientation for Windows 8.1
    VorpX set to Show on Rift DK2
    FSX set to 1920×1080, full screen selected

    I am seeing in some tests a popup in FSX from Vorpx warning me that DX10 is 2D only… why might it think I have DX10 selected? I definitely do not have the “preview DX10” option ticked.. I checked that explicitly.


    That sounds correct to me. If it doesn’t work this way, I would recommend to set vorpX to “Use system settings”, ensuring that it doesn’t interfere at all in regard to the monitor selection, and select the device in FSX.

    Just checked whether I remembered correctly, and this option is indeed available in the graphics settings. You have a listbox named “Device” there that contains two entries (assuming you have one monitor and the Rift attached to your PC). One of them is the primary, the other one the secondary display adapter.


    Thanks for moving this to its own thread Ralf. These things are tricky as there are so many different environments.

    I think you are right that its an issue related to the “device” selection, most likely by FSX itself. I had not used the FSX -> Settings -> Customize -> Device selection before. I see two devices there and tried to select the second rather than the first already selected. But no joy yet. All appears to work right up to the launch “Fly Now” and that then shows the “double barrel” screen on the main monitor rather than on the DK2.

    I have snapped the config screens and made notes… in the hope to document the eventual working system (I am always an optimist) at

    Using vorpX for Oculus Rift with FSX


    I tried to get my steam version of fsx working, using nvidia 680 and windows 8.1 64bit.

    I tried with convenient setup and with rift as main monitor. I usually ended up with black screen with large cursor.

    Vorpx seemed to take control of the plane scene in free flight menu.. there was steam popups and everything.. when I started the game, it usually started to my monitor, where it seemed to work and when I put it to window and moved it to rift. it seemed to work still, but when I maximized the window, it froze. same thing if I moved the maximized window to rift directly.

    I am not quite sure which monitor is which in the fsx settings, but I tried multiple configurations…


    My friend got FSX working quite well (please note: This isn’t the steam version.)

    What he did was run VorpX with FSXRift and everything should work out just fine :)

    Pretty straight-forward plug’n play :)

    NB: FSXRift is for proper headtracking inside FSX :)

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!