Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #11071

    I love the way FSX looks with Vorpx..Nice job Ralf…The 3D is very good outside the cockpit. When the consumer version of the rift comes out the Virtual Cockpit will be much more appealing and usable.
    ..Since this area of the forum is for Tips …I’d like to pass on this one…When in fullscreen mode headtracking is triggered with the Alt key along with the mouselook key (default shift+O}…at first I thought it was alt+enter which put you into windowed mode. Just the alt key will give you headtracking in fullscreen. Also if anyone is interested try your F16 with just your HUD..cycle through your cockpit views…very cool!! You can get excellent 3D outside the cockpit. Now for Ralf…I would love to see two improvements…One ..a way to remove the huge mouse cursor or to make it a less obvious small plus sign. It stays in your line of sight right now and is extremely distracting….two …IZ3D now defunct…had in their control panel a two setting 3D hotkey…So you could press a hotkey and have your cockpit look great in 3D ..press the other hotkey and the exterior environment would have excellent 3D.. You are talented and all but having great 3D inside and outside the cockpit is probably not doable. Just my two cents. The flightsim community is clued into the rift so it would be worth it. I’m sure there are many like me who will buy this for FSX alone. Thanks for the driver Ralf…Bill


    Im a going crazy: I tried several hours but didn’t figure out, how the headtracking with Vorpx in FSX works: I tried “shift + O”, “shift + 0”, tried alt+enter to enter window-mode and back, pressed the alt-tab – nothing works. And: At the window I see a big vorpx-curser, no normal cursor to handle the plane. Where is my mistake? Any ideas to get the headtracking in fsx working, would be appreciated.

    Thanks a lot!



    It is a little tricky …Hit Alt … then with the alt key remove the FSX menu bar from the top of the screen by holding alt to remove it. Map shift+O to a controller if shift+O does not work. When you map Shift+O to the controller the slider for shift+O in the FSX control settings needs to be slid all the way to the right. Press and hold that button until it triggers mouselook. It seems to work better after the first success. Hope that helps.


    I have had quite decent experience with program called fsxrift (see https://developer.oculusvr.com/forums/viewtopic.php?f=42&t=752&start=60#p52904 ) and another free 3d injector. I was looking forward to using vorpx for superior experience, however I am having some small problems:

    – built-in headtracking using mouse and shift-O mouselook mode is just crazy, can’t make it behave in any reasonable way (probably mouselook is just not the way to do it)
    – when trying to use fsxrift, I get error that oculus headtracker is already in use, even if I disable headtracking in Vorpx in-game options.
    – when I start fsxrift before FSX, then I get pop-up from vorpx, complaining about not being able to access headtracker (naturally). When I start the mission (headtracking should still be disabled), game just crashes.

    The looks are much better in VorpX, so if this little crash would get fixed, I would be very happy. Also it would make the rest of the game much more usable with rift (with edge peek and mouse usage), and it would solve the mouse cursor hugeness issue, as you could just move the mouse away from the central area of the vision.

    Of course, it would be even better, if VorpX would implement SimConnect code to move around the view in the cockpit (I don’t think there’s much code to it), but I can understand if Ralf feels reluctant adding specific code to the driver to communicate with just one game.


    keegi…you do not need fsxrift with Vorpx. As far as I know only vireio makes use of it and maybe tridef. Just use mouselook with Vorpx for headtracking. Read my previous posts to get it working. I would also remove anything you did with vireio out of your FSX directory.


    I had no problem to get mouselook working, but apparently I did not understand the sensitivity slider correctly. It was moving too fast for me, so I tried moving it all the way to the left, which actually made the view act really laggy. Moving sensitivity all the way up (and deadzone all the way down), and adjusting head tracking sensitivity in the in-game DEL menu, I got the head tracking working quite tolerably. Except now I really still miss the neck modeling from fsxrift :(. Still, it is quite good improvement.

    For reference, my settings (ones not mentioned are at default)
    – Mode: Z-Adaptive (Geometry mode looks very wrong from inside the cockpit, as if wings are glued to the windscreen)
    – Depth of Field: off
    – HT sensitivity: 0.23 (more precise value for me would probably be around 0.20, but 0.23 felt comfortable enough and gave less neck strain when looking over the shoulder for aligning for base leg)
    – HT smoothing: off
    In FSX:
    – Settings/Controls/Control type: Mouse Look
    – Sensitivity (all axes): 127
    – Null zone (all axes): 1


    keegi…try to adjust your Geometry mode …it’s definitely the best of the three. Eye Separation should be 1.0 or more all other settings on that page should be 0.00. On the following page of settings I adjusted the vignette. Geometry looks good in the cockpit and very good outside. You are doing something wrong if your wings look glued to the windscreen.


    Forget the mouselook, use FaceTrackNoir pre alpha 1.9 (downloadable from the older fsx thread on another forum about fsx+oculus, just google it), and emulate trackIr.


    After some googling & tinkering I found the killer setup together with up to 6 degrees of freedom headtracking (meaning you can lean forward to read your cockpit instruments from up close, you can go up with your body to look above the cockpit, you can lean left/right etc.):

    You need two instances of opentrack open at the same time (because the SimConnect protocol is broken on the latest versions, which however offer the best Rift headtracker support, I’m using both a new and an old version, which I connect to each other via UDP protocol).

    First instance: opentrack 2.0a8 (“server” instance):
    – Main tracker: Rift (leave all axes activated)
    – Auxiliary tracker: aruco (aruco works by scotch taping a printed symbol to the front of your Rift. Your webcam (I use a PS3 Eye) will pick it up and calculate your position). Disable following axes on this tracker: RX, RY, RZ, TX (as I do not want horizontal movement to place me outside the plane ;-))
    – Game protocol: UDP (use IP, port 5550, and allow in Firewall)
    – Axis inversion: TY
    – Make sure all curves are linear and “translation compensation” is disabled
    – Map Ctrl-Shift-Z to “center” key

    Second instance: opentrack 2.0a6 24 (“client” instance):
    – Main tracker: UDP (use IP, port 5550, and allow in Firewall)
    – Auxiliary tracker: None
    – Game protocol: SimConnect
    – No axis inversion
    – Make sure all curves are linear and “translation compensation” is disabled
    – Map Ctrl-Alt-Z to “center” key

    How to go ahead:
    – Run “server” instance, push start button
    – Run FSX/Prepar3d (works in both), skip error message that headtracker is already in use by another application (this is what we want ;-))
    When in cockpit, center view by pressing Ctrl-Shift-Z and Ctrl-Alt-Z
    – Run “client” instance, push start button (you need to at least run “stop, start” as soon as you are inside your cockpit for FSX to activate the SimConnect tracking)
    – Enjoy FSX in 5 degrees of freedom (6 if you also enable TX axis in aruco on “server” instance => as mentioned I prefer to disable it not to be placed outside my cockpit)

    aruco needs sufficient light to be directed at the printed symbol attached to the front of your Rift (just place a lamp in front of you, won’t bother your view as you wear the Rift anyway).

    aruco allows you to use a number of printed symbols for the tracking, however I am using http://www.outerra.com/images/787.svg (just printed from this page in the browser => credits to Brano Kemen => http://outerra.blogspot.be/2013/08/absolute-positioning-with-oculus-rift.html ).

    Also make sure you pick the highest refresh rate for the camera as possible (I am using settings of 120Hz and 640×480 resolution in the camera setup of aruco, in the preview window I get around 70-80Hz).

    Hope it helps & cheers ;-)


    Forgot to mention: Disable the “Roll” axis in the Rift tracker of the “server instance”, else looking down the roll of the rift will mess up your view.


    Okay, so I can kindof get the head tracking to work, by pressing the middle mouse wheel??? Huh? Oh well. The picture with the oculus on in FSX seems kind of like you are watching a big movie screen when you move your head. When the middle mouse button is pressed, it lookl like you are “in the program” so to speak.

    The REAL problem is: When I finally do get the virtual cockpit to display, and zoom out to about the right distance, I can only see the left side of it. No overhead, no right seat stuff, nothing…..

    SO, what am I doing wrong everyone?



    PS: Im an airline pilot in real life, and have used FLIGHT SIM for years, but I would REALLY LIKE to get this oculus set up to work.



    Hello all, I just wanted to mention eZdok camera for FSX.
    It’s a paid addon but absolutely worth it if you are serious about flying fsx with the rift.

    After some setting up, enabling TrackIr in ezdok got the rift working flawlessly. You can set your cameras up anywhere inside the cockpit & also outside with seamless transitions between views which feels doesn’t feel bad at all. If you do happen to get the mod, have a good read through the manual (It’s not very big). There’s also a couple of decent youtube vids on how to set it up like this one: http://www.youtube.com/watch?v=uIHbKrrzWDM

    The only difficulty left to solve is the ATC window being difficult to read, although it seems to work sometimes.


    Sorry, I think the option for the head-tracking is enabling mouse look per camera which then is effected by Vorpx not trackIr.


    Hi to all,
    Can get FSX to work really well with mouse tracking and a few adjustments here and there in game.
    The “DELETE” key brings up the VorpX in game menu and I’ve trimmed and adjusted things there quite Ok.
    But I cannot access the FSX top menu, usually accessed with the Alt key in FSX.
    This means for one thing that I cannot playback my flight!
    How does one look at the menu bar in order to access those FSX options?
    Edge peak doesn’t show the top menu bar either.
    In fact the ALT key when pushed seems to show just a grey-blue shadow on the right hand side of the rift.
    Apart from that it’s great!!


    Got it !
    In my case I used the Shift key plus the Middle mouse button and gained fairly easily access to the menu I mentioned.
    I did have to look way up and to the left in the Rift gogles…but there it was in all it’s glory.
    So now I can “instant replay” my flight. Sit back and gaze through all the views available whilst not worrying about crashes!
    It’s simply superb how Ralf and the gang have made this possible.

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!