G3D/DirectVR: Judder and Stutter most games

Homepage Forums Technical Support G3D/DirectVR: Judder and Stutter most games

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #216733

    hi thanks for reading.

    i’m using the beta vorpx version from the forum.

    i searched the forum for this problem and the only page in the first few pages of results that sounded helpful, when i clicked the link, the forum said the post was gone!

    i have a good enough system for anything except new AAA DX12 games to run at 200-500 percent resolution scaling, this isn’t an fps problem.

    i have a 90hz wmr hmd, a 75hz monitor, and geforce 2080ti.

    i get no stutter/judder in native steamvr or openxr games (so long as i keep fps over 90) this has only happened in vorpx. i also dont get the stutterjudder if i use vorpx in pure 2d mode or even Z3D mode. i have motion reprojection turned off in my wmr settings and my openxr for wmr settings, and of course both are also set to 90hz.

    here is when i get stutterjudder in vorpx and how bad:

    worst: G3D, DirectVR, Head tracking prediction On (this setting also causes extreme ghosting of moving objects, i found i get less than half as much stutter and ghosting by turning head tracking prediction off)

    very bad: G3D, DirectVR (ghosting and stuttering is still too bad to be playable)

    bad: G3D, immersive/cinema (might not improve at all, might just look a little better from being less zoomed-in)

    i have tried turning all headtracking options to the least judder modes, that doesn’t help. (judderfree, then safe/off) and also disabling headtracking totally, no difference.

    some games i get just enough less stutter for them to be playable they just could look a little better in motion (official elder scrolls) other games way too much stutter to even enjoy (cloud profile homefront). official profiles run a little better most of the time, they are playable and enjoyable but the problem is still at least slightly there.

    one official G3D profile i tried worked perfectly fine: warband.

    all wmr and openxr drivers are newest, regularly updates. never used another hmd so no conflicting settings anywhere. vsync is turned off everywhere it could possibly be turned off.

    please read this post before replying, i will ignore replies that dont take account of the info i posted. please also try not to just post one-line replies, explain and offer multiple stages of tweaking in case your first suggestion doesnt work. thank you.


    I know you say it’s not an FPS problem but I think it is. 2080ti is a pretty damn weak GPU for vorpx. IIRC alt+F enables the fps counter so check that. Can’t think of anything else.


    this post isnt a reply, i’m adding some more observations and bumping for help. if i posted in someone’s thread and they let me know my views weren’t wanted i wouldn’t keep posting there.

    it seems like G3D has less judder the lower the direct3d version is, for example i get a lot less with warband and oblivion (both dx 9) than i do with other games that are 11/12 directx.

    there are tons of differences with how d3d less-than-10 work compared to recent directx versions for stereoscopic 3d, if vorpx uses any of the same tech as 3dvisionfixes or related software. most people wouldnt know or care about that stuff but if there is some relation between the methods used by vorpx and any 3dvision-based tech, then the series of video card used versus the version of directx used can cause all kinds of problems. until recently tons of 3d fixes needed a 2000 series card or earlier in order to work with certain direct3d versions.

    tons of 3d stereoscopic software got ditched from nvidia drivers with the launch of the 3000 series so it’s a reasonable concern that vorpx, which was created before that series, might have had to include fixes for newer tech and there’s something not working right between my particular model of card, my drivers, newer direct3d releases and the current vorpx version.


    cant edit last post to add this other note i should’ve mentioned earlier:

    the biggest problem is ghosting (which is obviously different from judder/stutter and that’s a problem with a couple games but it’s secondary)

    i dont expect help anymore but to try to describe it anyway, Z3D/2D looks how the game should look, G3D on the DX3d-9 games I’ve tried looks like a decent plasma tv with a little acceptable motion blur, G3D on DX11/12 looks like TAA plus a cheap LCD TV…but only when something moves across the view quickly, otherwise it’s perfect high-fps clarity. and yeah obv in-game motion blur is off ofc.


    i read about motion reprojecting and the ghosting that causes, although i have all motion reprojection settings off in all possible settings of all programs, the image quality problem sounds like it must look pretty similar, just to give you some idea of what the problem looks like.

    should’ve just started by mentioning ghosting i guess but right before posting, the last game i tried had the stutter problem and was particularly bothersome, got my post on a sidetrack i guess…although both problems are bad and totally inexplicable

    the stuttering game i just mentioned is from 2011 and people were playing it through vorpx on like geforce 980s and 1060s so whatever


    Please check the performance optimization section in the vorpX help if you haven’t done that already. Given that vorpX exists since 10 years you can probably imagine that you aren’t the first one with questions regarding performance. To make getting answers to these questions easier for everyone all relevant information in that respect has been compiled into an existing help section years ago.

    If you still experience issues after the suggestions given there and are 100% sure that a game you are trying can run safely at >200fps monoscopic, which would be necessary to reach 90fps with G3D (including a little safety margin), check the trouble shooting guide, especially the part regarding apps that may cause a conflict by also hooking into games.

    You may also want to experiment with the sync/fps limit options in the vorpX menu. If a game can’t reach your full headset FPS, reducing the FPS to half of that can enhance the perceived smoothness compared to running at an uneven fraction.


    hi and thanks for the response

    with all respect what surprises me is that with vorpx being in development for more than a decade that the help section seems very generalized and abstract. there are user-maintained wikis and reddits for all kind of programs and games and tech that are more specific and technical. i have followed 3dvision-fix development and for example in that field you can read about specific shader problems and settings only accessible through nvidia profile inspector or the windows registry, meanwhile for vorpx if i go into the Z3D/G3D editor modes there is nothing but trial and error to guide me.

    in your development of vorpx have you ever encountered ghosting and stuttering unrelated to PC specs or running services/programs? was this like unheard of until i had this problem? what is surprising is that there isn’t already specific help for the exact problems i’ve had.

    unfortunately it sounds like somehow this thread got onto the track of looking at this as a problem with my pc’s rendering performance, i don’t know how when i’ve been so careful to mention repeatedly that the issue isn’t frames per second. whatever problem is going on has more to do with how vorpx is working than how my computer is working. native openxr and steamvr games at super high settings without either stuttering or ghosting. like with my other posts in this forum i get the feeling they’re not even being read. i half expect a helpful “microsoft tech representative” to show up and tell me to run troubleshooting command.exe prompts.

    i have tweaked my games and system for the best performance, and in the game with the worst stutter i’ve had so far (homefront 2011) i have also tried playing it at a super low resolution and there was no difference in the suttering problem.

    my OS is win 10 64 Pro setup using NTLite to strip out all possible slowdowns and services, for an esports gaming pc. i take the same approach to things like overlays and all other programs mentioned in the troubleshooting guide. nothing has ever been installed that would cause any kind of lag or get in the way of the cpu/ram/usb. there was never a single byte of onedrive or skype on this system.

    i run at 1:1 bus-to-ram speeds to eliminate all forms of stuttering. this system is tuned so tight that i don’t have all my USB devices running, don’t have unnecessary services like printers even installed, and my e-cores are disabled to achieve full ring bus speed on the remaining 8 p-cores which have had all c-states disabled except for the several required for the low-core-usage turboboost to kick in. anything i don’t use is totally disabled both in bios and on a driver level through control panel.

    i don’t expect every single game i try with vorpx to work perfectly but when i have tons more problems with specific games than other users with lesser PCs report, and when i have specific problems that nobody else mentions, obviously vorpx is not working as intended on my system. and im sorry but even after your reply here (which i appreciate) i still feel entitled to more help.


    If you indeed went thoroughly through all trouble shooting steps there unfortunately is not much more that can be done. As you correctly noted yourself your issue is a highly individual one apparently. Only you can do the actual diagnosing on your machine, all anybody else can do is hinting you in potential directions which is what the various guides in the help are for. Thanks for your understanding.

    If not even older games in Z3D run at stable 90/90 (or 72/72 on Quest at default), use ALT+F to check that, something is so severely off that the best course of action is probably trying a fresh Windows install. Won’t solve any potential hardware config issue, but would at least rule out software related problems.

    As suggested above before you do that try setting a game FPS cap in the vorpX menu, 45/90 (36/72 on Quest at default) may feel smoother than an uneven ratio like e.g. 65/90.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!