Geometry 3D causing artifacting with shadows, looks ugly

Homepage Forums Technical Support Geometry 3D causing artifacting with shadows, looks ugly

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #208004

    I’ve been trying to custom profiles for Kingdom Hearts 3 and Tales of Arise, but the only setting that produces the 3D effect i want is Geometry 3D. Z-Normal and Z-Adaptive won’t work. And when i use Geometry 3D it looks really ugly due to pop-in textures and shadows.

    How do i fix this? I’d prefer to use either Normal or Adaptive, they look much better in other games like MCC. I don’t know why the custom profiles dont seem to work


    Shadows often can’t be easily steroized and thus have to get some extra treatment. The user profile author may just not have been annoyed enough to care or maybe the profile was made for a different program version, which often breaks shader definitions for shadow treatment.

    If you want to invest a little bit of time, you can try to fix this yourself.

    1. Enable ‘Expert Settings’ in the config app (‘General’ page)
    2. Enable ‘G3D Shader Authoring’ on the same page
    3. In the game press CTRL+END (or ALT+END) to open the shader authoring

    May look a bit daunting at first, but is really fairly easy, even if you don’t really know what shaders are. You basically flip through the various vertex- or pixelshaders a game uses to find the offending shadows, then add them to the known shaders and define them as shadow (or just disable them).

    Sounds more complicated above than it actually is, and if you happen to be a bit of tinkerer, that can even be some fun on its own.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!