Getting extremely low FPS on 980ti

Homepage Forums Technical Support Getting extremely low FPS on 980ti

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
  • #103709


    So i just bought vorpx, and im getting REALLY low fps in most games.
    Dishonoured for example runs at over 150-200fps on my monitor at max settings. But with vorpx geometry 3d, even at a lower resolution with settings turned down im struggling to get 30.

    Its fine if i go up against a wall or something where its not graphically intensive, but general gameplay is practically impossible

    Deus ex human revolution cant even get 20fps on medium settings.

    Is this normal?

    I have an i7 2700k OC’d to 4.6 GHz and a 980ti


    Try to disable OC, just s guess though. I used to have some issues with older games some time ago even without VR when CPU was OCed.


    Yea, something strange is happening to your setup.
    I have a 980Ti as well and skyrim plays at 90fps with 2x upscaled resolution in geometry mode.

    Try reinstalling the Nvidia drivers and then maybe see if your runtime is updated too.

    Are you using Windows 10? cause Windows 10 is know to mess up random stuff for some people.

    Could also be the CPU. While very strong in benchmarks, for some reason the 2*** generation Intels are having weird issues in recent stuff. Heard of many guys who went from 2500k to 4*** or 6*** and say even though their clock speeds are lower, their gaming performance got much better.


    Not all PCI express lanes are made the same. Its possible the added stress of processing 3d is brain raping your cpu. Im running a 3930k at 4.8 ghz and an asus strix gtx980ti oc, and I dont have a frame rate problem, i have a vorpx not really working problem.


    So ive tried reversing the OC on my cpu and completely reinstalling my OS.

    Still same issue

    Certain games like half life 2 run absolutely flawlessly, however some, such as deus ex, run at maybe 5FPS on the main menu, even with 3d reconstruction disabled.

    Whats going on?


    I also have a 980ti FTW, i7 processor. Just bought Vorpx yesterday but I’m getting 23-30 fps. I haven’t seen any game perform that bad. I just built this computer with solid state drives and ddr4 16 gb memory, I feel like I should get better fps even at max graphics.


    Something is very wrong on my end with Deus Ex Human Revolution + vorpx, especially, when using DX11. I’ve tried both versions. With DX11 enabled, framerates are abysmal, similar to yours with G3D, Z3D, even 3D off. I was messing with it last night. Setting it to DX9 yielded better framerates, but it didn’t seem like ATW was working. Lots of stutter when looking around when framerates drop below 90fps. Other titles, for example, still have buttery smooth headtracking even at 30fps, so it leads me to believe something is wrong with timewarp – either the oculus SDK or vorpx’s version. Also, for one of the games, the Z3D modes defaulted to 0.00 3D strength. When raising this setting, it seemed to alter IPD instead of 3D separation. Also, CPU usage was @ 100%. Weird stuff going on that I think is game specific.

    Dishonored, on the other hand runs very well on my system. In most cases, framerates are high enough not to notice issues. I see drops when there are a lot of AI wandering about the larger outdoor areas. In those cases, I switch to Z3D for a spell. The Hound Pits pub is notorious for lower fps, though.

    2500k @ 4.4ghz, GTX980sc


    I’m having the same problem with Deus Ex, I have a 980ti and only get 11fps in DX11.
    Has anyone found a solution for this?


    That is REALLY odd. Deus Ex: HR is one of the test games here that are checked quite regularly, last time yesterday incidentally (GTX 1080, which finally arrived here yesterday, is great for vorpX BTW).

    Please try to reset game settings to default, set resolution to either 1280×1024 or 1600×1200 and do not force AA in your graphics driver (just in case).

    Usual test case here is Sarif HQ, which is a good test area since it shows a wide range performance wise. With minimum VR spec hardware (GTX970) and Geometry 3D in DX11 at 1600×1200 that should be OK performance wise mostly with a quite heavy performance drop (~20fps) in parts of the main lobby.

    Anything below the result described above definitely is not right.

    Apart from that: what helps quite a bit performance wise is using the max. ingame FOV and compensate for the rest with the vorpX inmage zoom instead of using the FOV set by the vorpX game optimizer. That is basically true for any game, but especially for Deus Ex. Enhances both performance and image quality at the price of visible bars with low zoom settings.


    I’ve reset the game a couple of times, change resolutions, turned different graphic settings on and off. I even downloaded the non directors cut version (which has the same fps issue)
    I also get low fps in z-buffer mode after 10min of playing, when using DX11.
    I’ll probably just play using in DX9, even though it’s not 3d.


    Hello Ralf! I am currently playing this game and I followed the tips you gave, so I think there’s something wrong with Direct X 11 in game AND THE LATEST VERSION OF vORPX. I am in the Sarif HQ if I turn off direct X 11 my frame rate is perfect, if I turn on direct X 11 I end up with 4-6 FPS, I have a GTX 1080 I am running 1280×1023 4:3 I tried without antialiasing. Could you take a look? Thx!


    The DXHR DX11 framerate issue is a *really* odd issue. I had it once myself, but when I actually wanted to check what might cause it later, it was gone again and I could not replicate it…

    Pure guesswork, but my assumption is that some graphics driver or game setting or a specific combination of both causes it. Try to reset both the game’s graphics settings as well as your graphics driver settings to default. Maybe that helps.

    You can also switch to DX9, IIRC there is not much of a difference, neither performance nor quality wise between DX9 and DX11.


    In DX 9 I can see 2 black flickering lines left -right I did reset the graphics and same result. I am on he Vive BTW could there be something with Steam VR? I am going to do a few test again later. Thx for the answer! :)


    I’ve been having problems with VorpX too lately. GTA 5 no longer works and I sent a trouble shoot report to VorpX support but got no response.

    Other games (doom) dont seem to work as well either. Also on a GTX 980Ti. Think its maybe since the update. GTA 5 runs fine without VorpX but vorpX on and frame rates tank, mainly at night but this never used to happen. Resetting to Default doesent help, I tried clean reinstallations and putting graphics settings on the lowest possible. It didnt even seem to register a change.

    Just tried again was getting 20 FPS in the day time down to 4 at night! Something is very wrong!


    No comment ralph? Can you tell me if you even recieved my email with the report attached?

Viewing 15 posts - 1 through 15 (of 19 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!