How to G3D and hit 80+ FPS and High Definition

Homepage Forums General vorpX Discussion How to G3D and hit 80+ FPS and High Definition

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #199706

    How’s going? I am using Vorpx about 1-2 years and while fixing problems, learning about the tool, tracking perfect settings to play games in G3D, I found out solutions for those who do not want to play in low resolution while VR’ing.

    I’d to share with the users and the owner how I play G3D at STR 1.0 (usually 2.0) up to 5.0 (making things smaller/super rounded) getting 80+ FPS yet in higher definition (almost as playing 1440p/4k).

    I do a i7 6700 and a GTX 1070;
    I use Pimax 5k+ with larger FoV;

    First, such trick can be used not only for Vorpx, but all VR games. Secondly, since I’ve experienced and still am ATM, such improve, I’d need Ralf’s or anyone explanation is what am saying is right or not, feel free to correct me.

    Pimax users>

    In Pitool, w/e you do, as begin, use Render Quality = 1.0. The FoV and reprojection can be large/On

    Go in SteamVR’s settings right clicking in the menu->Config-> go in tab “general” or the first tab, set “Render Quality” to manual. A slider will poop up where you can increase SteamVR’s Default 25%/50% up to 400, indicating just below the new resolution the supersampling will apply. Usually, with Pimax RQ = 1.0, I use it at 75%/100%, increasing my pixel’s density first, at 50%, from 2160x up to 3048x ou 5560×2632. You can test lower or higher resolution increment, depending of the game. If you go in the tab “Video” There’s the option of costumazing SS for every game listed in Steam. But if doing so, you have to equilibrate it with the Render Quality in “Geral” said above.

    In the game, set the resolution down of your choice, up to 1440×810 in 16:9 or any below or equal 1080p (1920×1080) depending your graphics can go higher and, test it out.

    The supersampling in SteamVR works great to compensate lower resolution judders and/o the aspect of low resolution we are bothered with, almost making it a native 1440p/4k game, plus, you’re able to play any game with G3D on, at 1.0 or higher (I am used to set it 2.0) with high definition and high FPS.

    Extra adjusts I am used to do in-game, in the vorpx menu (DEL)

    In the “Image Settings” Tab:
    Sharpen Amount> I set it from 0 to 1.0 or higher in order to bring sharpness to the game. You can alter brightness a little if you wish too
    In the “Display Settings” Tab:
    Headset Sync: “Safe”.
    Device (Fast) and fast makes my game stutter/lag, at least with my Pimax headset
    In the “Direct VR Settings” Tab:
    Change Game Settings> “Off”
    I believe Vorpx will pick resolution/graphic settings according your spec and-or what your machine can handle yet keeping decent framerate. I haven’t tested keeping it on but in case you’re setting your own resolutions/image qualities.

    Playing with lower resolutions allows you to turn all or almost all game’s quality settings to max/high/ultra yet SteamVR supersampling allowing you to see the image as good as playing in 1440 or 4k, in the Headset. Play FullVR or Immersive Modes in G3D, with similar quality at 70-100 FPS

    Tip: Some games and VR games may not like high SteamVR SS settings due either they starting at a default quality/resolution or due them VR native games having high resolutions set by the player. Care in not setting super high values or test it out and do not forget you’ve SS beyond the default. That’s possible supersampling each game you have, as explained above, case you wish doing this only with X or Y game/application.

    Any other tip and-or suggestion/correction is welcome



    The last time I checked, Vorpx ignored SteamVR supersampling. Have you checked your pixel density to verify your changes are working?


    @ Ogrescar. Cool, interesting, works in all games but I’ haven’t tested Vorpx/SteamVR supersampling combo that much. But if Ralf said that that doesn’t go along before, then true.

    I know that Vorpx has its own resolution/pixel density settings (in “Change Game Settings” once On, I guess with max “1920×1440” if putting in “quality”, and, anything set above (Ex in game’s resolution settings) will “supersampling”? take place. Perhaps the game’s resolution took place over Vorpx one once I turned it off and, my equivocation equivocation came from there. Either it or due “turning off” let my image quality/settings in game take place.

    In normal games/Vr games works like a charm as said, I also don’t know if Pitool’s RQ works along Vorpx as well.


    AFAIK, supersampling in an hmd is just setting the render target to a resolution higher than it’s 1.0 pixel ratio. If you want to invoke supersampling from vorpx, you have to set your in-game resolution high enough to exceed that.

    Tweaks via SteamVR or Oculus Tray Tool or whatever may be reflected somehow in Crystal Image – you’d have to ask Ralf about that. Vorpx has the final say in the render target size, irregardless.


    vorpX sets the headset target resolution ‘intelligently’ depending on the game resolution within a defined min/max range, ensuring that it is always high enough to not have a negative impact on image quality whithout – on the other hand – wasting resources in the headset render stage that are better spent rendering the game.

    What’s important to understand here is that changing the headset target resolution does something entirely different in vorpX than it does in native VR games. Native VR games are actually rendered at the headset target resolution while with vorpX games are rendered at the resolution set in the game options. The headset target resolution only comes into play in a second step when vorpX renders the already rendered game image to the headset.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!