How to reduce aliasing/flicker in the Desktop Viewer?

Homepage Forums General vorpX Discussion How to reduce aliasing/flicker in the Desktop Viewer?

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #206921
    grumbel45
    Participant

    When using the Desktop Viewer I get a lot of aliasing, which isn’t unexpected as the resolution of the desktop is much higher than what my headset can display, and there doesn’t seem to be any filtering or mipmapping going on to properly downsample the image.

    If similar issue pop up in other VR applications, e.g. watching a 4k movie in SkyboxVR, it’s possible to fix it by cranking up the SteamVR resolution really high, as SteamVR itself seems to do proper downsampling. However SteamVR resolution doesn’t have any effect on the VorpX desktop viewer.

    Any other things I could try to reduce the aliasing/flicker in the Desktop Viewer?

    #206925
    Ralf
    Keymaster

    The desktop viewer image isn’t mipmapped on purpose since that would make it more blurry, but changing the Clarity setting on the image page of the vorpX menu from low to medium will raise the final headset resolution as well as enable high quality Lanczos instead of bilinear sampling. That should do the trick.

    #206929
    grumbel45
    Participant

    No luck. The Clarity setting doesn’t help, no matter if Low/Medium/High/Off or how the sharpness is set, the image always ends up with far more shimmering than I’d like.

    In comparison I can get a much more stable image with BigScreen, it’s not quite perfect there either, especially with smaller virtual screen sizes, but at least it looks usable. Only way I get a stable image out of Vorpx Desktop Viewer is by reducing the desktop resolution down to 800×600, but that is a bit too low to be usable.

    My setup here is a bit unusual however, AMD Relive WLAN streaming over to a Lenovo Mirage Solo. And the games I try to play are 2D point&click adventures or Visual Novels and the shimmering really stands out with those 2D games and the text.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!