HP Reverb G2 does not attach to anything

Homepage Forums Technical Support HP Reverb G2 does not attach to anything

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #207648

    I’m getting desperate…

    My HP Reverb G2 seems to be incompatible? I can use the device via Steam VR and Mixed Reality Portal without any problems.

    However, I can’t get any game to display anything at all in the glasses. It always just pops up the attach to… window appears without anything happening. Have also tried the alternative hooking method and the driver. nothing.

    All of course with multiple games, with and without local profiles. The glasses stay black! :(


    If you haven’t done so already, please first try the trouble shoot options that pop up in the ‘Attaching to…’ dialog after a minute or so. Most importantly the first one (‘Install hok helper’). Installing a hook helper can often help without having to get to the bottom of the matter.

    If that does not help, you have to dig deeper. Hooking issues almost always are caused by conflicts with other programs on your PC that also hook into games. The trouble shooting guide on top of this sub forum has more details on that.

    if you happen to use a gaming laptop, there are a few extra caveats. Also listed in the trouble shooting guide.

    BTW: Probably unrelated, but the Reverb G2 works best with the headset type set to OpenXR in the config app, not SteamVR.


    Hi Ralf,

    ive tried all the attach variants. OpenXR is already selected. Also tried SteamVR (does not work too)

    Ive running

    – AMD 5700XT Graphic Device, Hotkeys/Overlay disabled.
    – iCUE (Corsair Software disabled)
    – Anti Virus only MS Defender running.

    Reading Trouble Shooting Guide again.. 😥


    That doesn’t sound good. If you want, you can send me a trouble shoot data archive with some logs and additional system info. No promises, but I’ll take a look at it and let you know if I can see something unusual.

    Please create the archive in the config app (trouble shooting page) after trying to launch at least one (better multiple) game(s). Then send the archive via e-mail to support at vorpx com.


    Perhaps also interesting:

    As soon as I want to start the VorpX Desktop Viewer, the Mixed Reality Portal starts as expected. I can also catch a glimpse of the Dekstop. However, as soon as I move my head under the VR Device or press a Keyboard or mouse button, I only see a kind of loading screen on which several “balls” move. Endless….

    I’ll start some other games and create the support log. Thanks a lot for your help!!! :)


    Support File otw …

    thx a lot for ur support :)

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!