HP Reverb G2 head tracking issue

Homepage Forums Technical Support HP Reverb G2 head tracking issue

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #207540

    As of a few days ago, the head tracking of my HP Reverb G2 suddenly stopped working. When I change to SteamVR it works, but openXR does not, and SteamVR causes a large performance hit. Wondering if it’s due to an WMR update. I know the HP G2 had some issues in the past, but then were seeming resolved. Thanks for a fantastic product!


    Can’t really recommend anything else than switching to SteamVR in such a case (or restarting the PC and hoping for the best).

    There was an issue a while ago where OpenXR failed to init on WMR headsets entirely while native WMR (the WMR portal) still worked. I was able to track down the issue to the head tracking, so whenever that occurs now, instead of OpenXR failing entirely, only the tracking init fails. That’s probably what you are experiencing.

    There is no real pattern to if or when this issue occurs, at least none I could detect so far, and personally I haven’t encountered it in quite a while, so at this point switching to SteamVR is really all I can recommend if you encounter this issue.

    For better performance in SteamVR mode, try to disable ‘FluidSync’. However: WMR headsets over SteamVR are quite prone to judder, hence for this combination FluidSync is on per default. So if disabling FluidSync causes judder, you will have to live with the capped framerate.


    I remember when that happened. Did some posting about it. Then the problem disappeared for months.. so I wonder if WMR portal occasionally does some updating in the background that isn’t friendly with the vorpx cold.. because it just came back out of the blue and is relentless


    I’ve noticed a few times recently where I launch a game to soon discover there is no head roll or tracking – HP Reverb G1 OpenXR. It never seems to happen on a fresh portal boot or first game launch, but sometimes on a 2nd or 3rd game attempt. Rebooting the WMR portal seems to fix it, but I have not experienced this bug prior to Windows/vorpX updates this month.

    Along side this new occurrence, I can no longer play some Ubisoft games in OpenXR. I’ve been playing FC5 and FCNewDawn in OpenXR just fine for a month, but now I get an “OpenXR init failed” for both games. They still work in SteamVR mode, but with less ideal performance. Other games still seem to work fine with OpenXR, including the AC games. Odd.


    yeah it’s bizarre. rebooting or restarting the portal didn’t work for me. It hasn’t worked for the last week, but now I just started a game, and about 10 seconds after it loaded the headtracking kicked in.. so i guess i can use openxr again at least for now.. frustrating… but hey.. it’s working

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!