I could really use some troubleshooting help – major performance problems

Homepage Forums Technical Support I could really use some troubleshooting help – major performance problems

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #214778

    Hi all,

    I am really hoping someone may be able to offer me some trouble shooting suggestions as I am really tearing my hair out with this problem at the moment and have spent hours trying to resolve it without success. I have previously used VorpX reasonably successfully with a handful of titles when I first got my VR Headset a couple of years ago – at the time I had a 1080 Ti.

    I have had a bit of a break from VR, but was getting back into it over Christmas, and I now have a 3080 and a Reverb G2 headset. This should be able to run most titles very effectively with VorpX, but I am having massive performance issues in just about every title, and especially in Cyberpunk 2077, which is the main title I wanted to run VorpX for. Most titles I am getting FPSs in the region of 20 – 40, even at very low resolutions. With Cyberpunk 2077 the situation is even worse, the displayed FPS is in the mid-20s, but the actual display is far worse – if I move my head it can take several seconds before the rendered view updates to the new position (although animations, etc. can still be seen running in the background presumably at the displayed FPS).

    Things I have tried without seeing much of a difference:

    • The regular version of VorpX
    • The new beta version of VorpX (and using the option to fully reset everything to factory defaults)
    • The standalone Cyberpunk 2077 mod
    • Both OpenXR and SteamVR modes (little difference between them)
    • Install of the latest NVIDIA driver with clean install selected (even though this means I am going to need to set up all the custom resolutions again :( )
    • Using Task manager to disable every non-essential program that could conceivably be interfering (the only thing still running was GOG Galaxy as it is needed to launch Cyberpunk, but I have disabled the overlay)

    Is there anything else that I can possibly try in order to resolve this problem, or at least narrow down what might be causing it?




    Note, I forgot to mention in the original post, but the Graphic settings in Cyberpunk 2077 are set to Low with Raytracing disabled.


    Hi Ralf or anyone else, does no one have any suggestions of anything I could possibly do to try and narrow down what the cause of this might be? I have just updated to the latest beta release of VorpX (I did a full uninstall and reinstall), which may have improved things very marginally, but nowhere near the point of it being playable. Displayed frame rate in Cyberpunk 2077 is now around 30 for the game and around 70 – 80 for the headset, but the same problem persists that the actual update rate from turning the headset appears below 1 fps. Note that the game was started from within the virtual desktop with my main monitor turned off. Turning the 3D mode to Z3D or to Off has no noticeable impact and changing the game graphics settings between low and ultra also has very little impact.
    In case it helps to isolate the problem, the poor performance is present to some extent even in the main menu of the game before a level is loaded.


    Well I am pleased to report that I have managed to solve the issue. After a re-install I noticed that the judder was not present until I installed Cyber Engine Tweaks. Looking at the log files for CET I noticed that it was complaining about being unable to open a database file, so I wondered if it was some kind of weird file location or permissions issue, and had the thought that maybe it didn’t like being on a secondary drive. So I cleared up some space on my main C drive, and moved it across, and voila I am now getting stable 60 FPS in game and 90 in the headset!

    So in case it helps anyone else, if you are having problems, you might want to try moving Cyberpunk 2077 to your system drive.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!