IL2 1946 working!

Homepage Forums Game Hints and Settings IL2 1946 working!

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #110988

    I made this wonderful program to work and I wanted to share it…

    It comes from another forum but the process is the same.

    It really changes the way of dogfight…. impressive. With trackIr was cool but with this is AMAZING. I don’t get sick even with loops and crazy stalls… lol. Many people gets sick, not sure…

    After playing around a bit I found out it is not perfect (it is not made for this really). When you shot the 3d effect turns off, not sure why. So it looks like a machine gun shaking effect but x2 or x3. I have no idea why is that and I tried everything I could. Sometimes annoying sometimes doesn’t bother much. Maybe the stereo 3d never worked well, not sure, I don’t have a 3d monitor with me to try. I tried the stereo MOD but it didn’t work. The depth is very good. Everything in the cockpit is readable. Planes in distance are not perfect but you can see them and look at other planes in formation with a natural head rotation is very nice. You are there…

    Aiming now is very impressive. I can see the planes crossing below my plane and after I dive into them shooting at his tail…. really amazing guys….

    About how I made it (it wasn’t easy at all)…. I use mainly two programs…

    First I made a custom resolution of 1600×1800 (I have a Nvidia card).

    I edited the config.ini and I added this resolution and I turned off WideScreenFoV=0 and change the mouse pointer mouseUse=1 because you need the middle mouse button to zoom in and out the VorpX menus.

    For the head tracking I use Opentrack with the tracking of the oculus 0.8 and simulating a trackir (it works 360 degrees in all directions)

    Keep in mind the Opentrack doesn’t support oculus runtime 1.3 so I installed this wrapper to simulate the runtime 0.8 needed to run Opentrack. .

    This are the settings in Opentrack:

    Input: Oculus Rift runtime 0.8.0 — HMD
    output: freetrack 2.0 Enhanced

    I turned off all the filters in the “Filter” tab. (there is an empty one on top of the list)

    In Options-Output-Translation compensation I turned off “Enable” and enable “Disable Z axis compensation“.

    In Options-Camera-Center pose Offset I changed the value of TZ to 5.000 cm.

    And for the oculus I use a program called VorpX….

    The VorpX doesn’t support IL2 but it supports OpenGL. By default when you play it you don’t see 3d at all you just see 2d (it looks 3d but it is not). The thing I did is take the template for Quake (yes,, copy it and I changed the .exe to look at the il2fb.exe in my IL2 folder and it worked.

    At first the cockpit is out of the place but you need to change the 3d separation in the VorpX menu to 0.01 and then the magic turns on. The cockpits looks amazing :)) Remember to save the settings in VorpX menu.

    I play with the FOV at 90 (PageDn Key). You can play with the zoom settings (in VorpX menu) till you find confortable with the perspective.

    Another annoying thing is VorpX (at least in my machine) doesn’t run if head tracking is off and you need to turn head tracking off in VorpX menu everytime you load first time IL2.

    Just I don’t like the tracking in VorpX as it emulates a mouse. Opentrack much better.

    So… the way I do it is:

    1- Turn on the PC
    2- Open Oculus home (be sure the oculus is setup properly if not the opentrack gets confused)
    3- Open Opentrack and start
    4- Open VorpX
    5- Run the game
    6- As soon you are in the interface in game turn off the head tracking in Vopx (it should be amazing if they would add a trackir emulator)
    7- At first the menus and interface are in your nose. You need to press the middle mouse button and then it zooms in and out.
    8- Enjoy

    It is a bit of work at the beginning but I think it is worth it if you love IL2 1946 (by the way I am in HSFX 7 but I don’t think it really matters).

    Good hunting!


    Thank you!
    I will try this now, as I have a test build for opentrack that supports 1.4+ runtimes.


    Hello libory,

    the post is old, but trying your settings in il 2 1946 on my vive (and 3d separation in the VorpX menu to 0.01 setting, the name is no more 3d separation but found it easily), and it works great !! And for me the head tracking Inside vorpx for vive runs very nicely !

    Thanks a lot for sharing, will try it on il 2 cod to see if the result is the same.

    I have just a joystick problem (of nothing to do with vorpx, perhaps need to buy another joystick :p)


    And it looks like IL2 sturmovik just got official VR support in the v2.009 update!


    yes but it concerns only Stalingrad and Moscow (limited to the east front)

    But will buy it one day ! (but for now, 1946 is sufficient for me)

    I can’t have Cliff of Dover working (but just make a test and vorpx does not hook it). Perhaps a problem of administrator rights on the executable, need to check it.


    Would be nice if we were able to pm other members here, but as we can’t, I need to revive this old thread.

    Can you please confirm changing the resolution to a custon 1600×1800? When I do this, IL-2 refuses to even start.

    The first time I tried this procedure, I used my native HD res and it worked nicely, but far too zoomed in. I’ll try other res, but 1600×1800 does seem a bit strange. Is it supposed to be the res for one eye?


    Never mind – it’s sorted and the sim is just awesome in VR!

    Thanks very much, libory – would never have got there on my own.


    Hi everyone

    I’m try it to run IL1946 with vorpx but nothing works

    I’ve imported the profile IL2 1946 [Erkull], I’ve selected the profile in local games, I got a Reverb VR headset so I select the right option in Device Selection (SteamVR (index,Vive,WMR…)) and in Device Settings (Hand controller (windows MR))and VOPRX, WMR and SteamVR are open before run the simu (il2)… but when i start il2 nothing happens and the message “Attaching to il2fb. exe This takes quite a while. If you suspect the program hangs or you don’t want to use vorpX with to it, click the according button (add to exludelist) (close program) (do nothing)”

    What can I do??? Open the window and jump??? -.-

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!