Just got VorpX and 3d working with PCSX2 (PS2 Emulator)!!

Home Forums Game Hints and Settings Just got VorpX and 3d working with PCSX2 (PS2 Emulator)!!

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #179548
    legaiaflame2
    Participant

    The most important thing when using PCSX2 along with VorpX is to make sure in the “Configure VorpX icon” and within the “General” tab at the top, is to make sure “Enable Expert Settings” is checked off on the right hand side.

    This gives you the options which make the game 3d, or as 3d as they are going to get:

    So have 3d strength, Depth Weighting and Focal Distance set to max.

    Also, you will need to have PCSX2 set up with these settings:

    -Config/emulation settings/go to EE/IOP. In round mode select chop/zero and in clamping mode set to normal.

    -Config/emulation settings/go into speedcheck. Set VU Cycle stealing = 2.It should give you 60+ fps mostly all the time. Note: leave EE Cycle rate alone, just leave it at 0 as it can cause problems.

    -Config/Video/Plugin Settings. Try to at least set the graphics to 4X Native. This will take away the blurriness and smooth out the graphics. Which is a must to make the limited 3d settings in VorpX pop!

    -Config/Audio/Plugin Settings. Use Linear simple okay sound. And have disable effects processing checked off.

    So that’s it, enjoy your favorite PlayStation 2 games in VR/3d!!

    #179551
    legaiaflame2
    Participant

    If you need to improve the framerate you can also just set the resolution to 2X.

    #179559
    legaiaflame2
    Participant

    Also, use Z normal for 3d.

    #179804
    legaiaflame2
    Participant

    Also, if you encounter graphical glitches during gameplay or during cutscenes, lower VU Cycle stealing back down to 0.

    And just a reminder: Set the renderer to Direct 3D11 Hardware. Also, try to at least set the graphics to 2X Native (3X for better quality picture/resolution, if your computer can handle it).

    Lastly, If you have Steam and are using an XBox 360 controller make sure you go into the Steam launcher, go to “Big Picture Mode”/Config/Controllers and uncheck all controller options. If anything is checked you will have controller issues.

    #179951
    BenMcLean
    Participant

    Wow, I’m really excited to try this out.

    The games I’m looking at trying are the Kingdom Hearts series and Dirge of Cerberus. Trying Dirge first, but PCSX2 is doing this weird thing where half of the screen doesn’t clear each frame like it should. The wiki describes this as “bad post processing” https://wiki.pcsx2.net/Dirge_of_Cerberus:_Final_Fantasy_VII and recommends using software rendering to fix it. Eww, that’s awful. Anyone know of a way around that?

    Going to try Kingdom Hearts next.

    #179969
    legaiaflame2
    Participant

    Yeah, I’m glad I found a way to make the 3d work. Already been playing a bunch of games!

    I’m not sure about improving the framerate other than the things mentioned above. I know that if you use software mode you can’t upscale the graphics and everything becomes a bit blurry. It’s best to use Hardware mode with 2x resolution if your computer can handle it. If anyone else knows any other tricks let us know. Also, go to Config/Emulation Settings/Speedhacks and make sure you enable all of the speed hacks. But, maybe in your case, try disabling some of them and or setting VU Cycle stealing to 0.

    Anyways, these are the best VorpX settings to get the best view with PCSX2:

    -Game is best viewed in Cinema Mode
    -Use Z-normal for 3D
    -3d strength, Depth Weighting and Focal Distance set to max.
    -Screen aspect ratio should be set to 16:10
    -Click on “More Cinema Settings”
    -Set screen curvature to 3.00 or max

    #179972
    BenMcLean
    Participant

    Dirge of Cerberus apparently only displays correctly in software rendering mode. The emulator’s just bugged on that game.

    #188467
    Vsaphir
    Participant

    Hello there can we use opengl (hardware) setting in PCSX2
    and is VORPX is same, better than the PCSX2 3D plugin ? Thanks

    #188475
    TheLastStarfighter
    Participant

    Wow great work. I’m so excited to get this going. Any possibility of posting a list of working games? I can’t recall if BUST-A-GROOVE was ps2 or ps1.

    2060 RTX Super
    3900X Ryzen
    Can run pretty much anything.

    #188547
    TheLastStarfighter
    Participant

    Ok guys, how does this compare to the PPSSPP VR?

    I tried getting it to work tonight and to me it just looks like a big flat pancake?! There isn’t any stereoscopic 3D that I can see.

    However in PPSSPP VR, its 3-D and virtual in some games. I’ve tested an absolute ton of games and about 30 to 40% run really well… surprisingly some of the ANIME games work the best because the backgrounds are all done up in 3D and the character just look like well little cardboard cut outs…but who cares. Anyway I’m wondering if I just have my settings done up wrong on the PCSX or what?!?

    2060 RTX Super
    3900X Ryzen
    Can run pretty much anything.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.