Low FPS in Bioshock 2 Remastered

Homepage Forums Technical Support Low FPS in Bioshock 2 Remastered

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #217225
    Disco Machine

    Hey I was surprised and delighted to find the Bioshock profiles back on Vorpx so I wanted to try Bioshock 2 Remastered today.

    Everything is working well except the game is rather jittery/low fps. On my virtual desktop and FPSVR displays I have 120fps but on monitor it shows only about 30-50 fps, and that’s what it feels like in-game in the headset too. Jittery movement especially when turning around.

    And I can’t see why, when my PC is a 4080/i7-13700f that runs the flatscreen version at 500ish fps – this should be a cakewalk! Maybe I’m just doing some rookie mistake here? Any advice would be welcome!

    Disco Machine

    Update: Tried using Bioshock 2 original instead of Remastered (since this is advised anyway) and while the framerate is a proper 120fps here and everything is looking great, the game always crashes within a minute or so of starting a new game or entering the game world(it doesn’t crash while in main menu). The 3rd DirectVR scan (rotational) seems to be taking longer than on other games and making some strange in-game noises while doing so, but otherwise that works. There is no error message, just straight CTD.

    Seems this is a DX9/Geometry3D issue since I can play it fine with DX10 in z-adaptive mode. I tried just about any crash fix I could find like allocating more memory to texture streaming, as well as giving both VD and Airlink a go, but no luck… Can anyone else get this game to work with Geo3D in Vorpx?


    If you are currently using the regular vorpX, try the beta. I recently took another stab at this completely unexplicable Bioshock 2 crash issue, but couldn’t replicate it anymore here. I’m still unsure whether it really is gone, since I didn’t change anything spcifically to address it, so I might just have gotten lucky, but it’s worth a shot. Maybe it’s really gone this time.

    As far as the remaster is concerned, you should easily be able to run it at 90fps. While the Bioshock remasters technically are fairly bad DX9>DX11 ports with an insane amount of unnecessary overhead caused by replicating DX9 behavior with DX11 instead of rewriting the game renderer in ‘true’ DX11 fashion, on your rig that shouldn’t be an issue.

    Not much to recommend here except checking for tools that might interfere by also hooking into games.

    Disco Machine

    Tried the beta today, but no luck – just the same problems as before. Guess I’ll just play it in Z-normal, it looked pretty good in that mode, as well.


    hello, from what I remember, I had to remove the antiasialing because effectively: fps low

    Disco Machine

    Thanks I will give that a go later, Sylvan. The weird thing about B2 Remastered so far is that lowering everything both in-game and in Vorpx settings doesn’t seem to affect it at all, and my GPU/CPU aren’t really struggling whatsoever (they are low green in FPSVR). It’s like the game just decided to be 30-60 fps no matter what. Playing it in Z-normal puts it at a good 90fps right away, which is the same fps as I have set in Virtual Desktop. It’s a shame original B2 crashes because that one works perfectly before doing so.

    I’ve had some more luck with Bioshock Infinite though. Seems to be working well enough, apart from some occasional stutters and the text being so small that I can barely make it out. Will have to test it some more though.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!