Low FPS in Skyrim

Homepage Forums General vorpX Discussion Low FPS in Skyrim

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #104116


    I get really low FPS in Skyrim when using VorpX ~22 FPS

    I tested with tridef, to see if my system isn’t powerful enough, but I get solid 60 FPS using tridef

    I tested:

    – VorpX stock settings
    – Turning Async timewarp on and off
    – Turning shadows on and off
    – Changing resolution
    – Changing skyrims graphic settings

    But none of this affected the framerate by more than 2-5 FPS
    Does anyone know what might cause this ?

    Rift CV1
    Windows 10 x64
    i5 6600k 4.5 Ghz
    GTX 970
    8 GB DDR4


    You can’t compare vorpX to monitor S3D rendering. vorpX is quite a bit more demanding since 1. It renders two full res images instead of two half res images and 2. a second render thread is running in parallel that copies the final image from DX9 to the DX11 based rest of vorpX, which is necessary since the Oculus runtime does not support a DX9 direct mode. On top of that the Oculus runtime itself drives yet another render process.

    22fps still looks very low. You should get ~45fps on medium to high settings normally with Geometry 3D in most parts of the outside map (less in towns and areas with dense vegetation, more in dungeons). Just in case you are using an insider build of Windows 10: go back to a non-beta Windows 10. Insider builds may break parts of vorpX at any time.


    This wasn’t meant so much as a comparison, but more as a test, to see if theres something wrong with my system or skyrim settings in general or if I only get low FPS using VorpX + the Rift.

    Also, VorpX and Tridef had almost the same performance a while ago on a fx 6300 and runtime 0.8 (both around ~30 FPS).

    Other games like Bioshock Infinite (50-90 FPS) run fine though.


    Try creating a custom resolution in your nvidia settings (1080:1200)

    Then edit skyrimprefs.ini file located in my games (C drive) to set that resolution in game (if the launcher would not allow you to pick this one)

    1080×1200 is a 1:1 rift resolution so everything looks way better than on 1280×1024 or 1600×1200 resolutions and it works a lot faster.

    If aliasing is a problem you can always set some antialiasing (x2,x4,x8) to make it look better.

    It should help a lot with fps.

    Additionally you can use one of the Z-buffer modes (ok&save + game restart required to take effect)

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!