major issue with vorpx desktop viewer

Homepage Forums Technical Support major issue with vorpx desktop viewer

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #211173


    for some reason, with some games, i have very low performance when playing those games with vorpx desktop viewer when the game is “on top” like getting half fps 45 fps at best, or even lower.

    however when the game is running in the background and when i switch on it but it’s still on background (no sound) but can still use controlers, i have full fps, no slowdowns at all, i was not able to fix this for days, so i’m kinda desesparate, and i hope someone can help me.


    You shouldn´t use desktop viewer at all and only for certain cases.

    You must make vorpX “hook” into games, for getting the best results. If vorpX does not hook then installing “hook helpers” can do it.

    If you´re not much familiar with vorpX-hooking then you must read yourself into it, otherwise you can´t get the best out of it.

    I for example, often don´t even use 3D-features and only use vorpX to play games on a huge theater-screen, but also there i am always using the hooking-method in the first place and even if it is just a pixel-graphics sidescroller.


    i think issue is reshade vr doesnt work well with some games when using vorpx desktop viewer :/


    Have better luck with reshade and desktop viewer when the game is in bordeless windowed


    thanks for your return and help guys.
    i fixed my issue using another software which works flawlessly.


    There shouldn’t be any need to use the desktop viewer for games normally, it’s really just a little freebie meant for doing desktop tasks. Regardless of the app you use desktop grabbing always has severe disadvantages compared to hooking into a game directly, which is much preferable. With the the exception of a handful of Vulkan games (currently not supported by vorpX) and games protected by anticheat systems vorpX should be able to hook pretty much anything you throw at it.

    If vorpX doesn’t hook into a game automatically, try to create a profile by making a copy of another game using the same graphics API. I.e. for DX12 games use a DX12 profile as a base, for DX11 games use a DX11 profile as a base and so on.

    You can find more detailed information on the topic in the vorpX help under ‘User Profiles’.

    IMPORTANT CAVEAT: make sure to assign the actual game .exe, not any launcher the game may use. E.g. some games may have a launcher named GameXYZ.exe, but the actual .exe may be in a subfolder, e.g. bin\gamexyz-win64-shipping.exe or something similar. In such a case you’d have to assign the latter to the profile. The easiest way to find the actual game .exe is checking the Details tab in Task-Manager while a game is running.


    The SBS setting in VorpX only shows with desktop viewer for me. Want that for superdepth3d/reshade on occasion when there is no profile for a game. Is there a way to get it to show when VorpX hooks?


    I’m having this EXACT issue with Star Citizen, been struggling for two days trying everything to get it to work.

    I captured the problem with OBS:

    EDIT: Notice the fps doesnt actually drop, only the headset ms tanks

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!