Metro Exodus crashes on start

Homepage Forums Technical Support Metro Exodus crashes on start

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #202075


    Metro Exodus on its own works fine. When i try to start it with vorpx it says something like “vorpx hooking with metroexodus.exe” and metro trys to start. But there only is a blackscreen and then it just closes again. I have it on the Epic Games Launcher.

    I tried a loot of steam games like MH:W or Assassins Creed 2 on uplay and they work fine no problems.

    I tried changing settings like DX11 or DX12, different resolutions, windowed or fullscreen etc. no luck so far. I restarted my pc started everything as admin or non admin. Tried the “alternate hooking method”.

    I use the standard local metro exodus profile.

    Do you have something i can try? Great software btw and amazing support on the forum, thank you Ralf :).

    Windows 10
    GTX 1080
    Xeon E3 1231

    Oculus Quest 2 via Cable with Oculus Link


    Just checked the Epic Store version of the game with a Quest 1. Worked here except for the first launch where vorpX adjusted some game settings. Definitely has to be DX11, vorpX should take care of that automatically though. If you happen to have disabled automatic settings, please re-enable that. vorpX often adjusts settings that are required for games to run as they are supposed to.

    One thing I noticed is that the Epic Store apparently has some new EpicWebHelper.exe that vorpX tries to hook. Makes sense to exclude that. I’ll add it to the exclusion list for the next vorpX release, for the time being you can do that manually in the config app under ‘Excluded Programs’. Just click ‘Add Process’ while the Epic Store is open and then select ‘EpicWebHelper.exe’. If it worked, you’ll see an according entry in the exclude list. Afterwards close the Epic Store and restart vorpX. Make sure the Epic Store really exits and not just minimizes as it does per default. If in doubt, restart Windows.

    If afterwards you still encounter this issue, it’s time to consider some other hooking conflict. If you happen to use any other antivirus than Windows Defender, do yourself a favor and get rid of it. That can’t be said often enough. There is no need for invasive third party AV on Windows 10.

    If that also isn’t the issue, there might be some conflict with some other tool you might have running. The trouble shooting guide on top of this sub-forum has more details on that.


    Thank you for the quick response. It works now, but i sadly have no idea what exactly was the problem.

    I added the epic web helper to the excluded programs, but that didnt change anything. I reinstalled Metro Exodus and that didn’t work either. Because it always crashed i got an error window popping up when i launch the game which asked me if i want to start in save mode. I tried that also but no luck.
    I also tried to start the game from the folder, without the epic launcher even up. And that didnt work either.

    Then i enabled the “dont optimize game settings” and also started the game in save mode at the same time from the folder. And suddenly it worked.

    After that i unchecked the “dont optimize game settings” again and started it again. And it worked without save mode.

    I now can just start the game from the epic launcher no problem with vorpX optimizing the games settings and it just works as intended. NO IDEA why. I just tried different things, no idea what exactly solved the problem.

    Well maybe this helps someone with the same problem. Even though its a little random, im glad it works :D


    I had the exact same problem with Metro Exodus (topic is called Metro Exodus benchmark, just little scrolling down this forum). Manually changing fron DX12 to DX12 and restarting the game, VorpX attached sucxesfully and also changed the settings properly.

    So i think there’s definitely something going on with the autosettings for this game.


    There is a sort of expected crash when on first launch vorpX changes the DirectX setting from DX12 to DX11. Worked for me afterwards, but maybe for you guys it crashed before the setting had been saved. Just a guess, but that would indeed send you in a loop where the game crashes on every launch until it is set to DX11 manually. I’ll check whether I can handle this first time situation more gracefully, shouldn’t be too hard.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!