More Judder with i9 XMP ram

Homepage Forums Technical Support More Judder with i9 XMP ram

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #216881

    Curiously, I experience a lot more judder with my new i9 CPU in most games. I retried with the i7 I previously ordered and it’s more stable.

    The computer is the same (except for XMP DDR5 RAM instead of regular DDR5).

    The GPU is a 4090 so it’s powerful enough. I don’t really understand why the i9 would cause instability. Maybe the RAM ?

    Even without “Judder protect” mode, I had less problems with the first computer, which was less powerful. I would like to determine if it’s a software or hardware problem, and how to fix it.


    Correct me if I’m wrong, but from what I understand, judder (I mean VorpX screen moving and jumping anormaly when I turn my head) is caused by unstable framerate, not by weak framerate.

    I think that even if my i9 computer is more powerful and make more fps, framerate is less stable, so there is more judder.

    Is it possible ?

    When I play FPS game like metro it’s harder to see and it happens less, but with Diablo IV, without profile, or with Desktop Viewer, Headset framerate is sometimes below 90, and game/desktop framerate is moving a lot.


    Ok…I think I’ve found the problem.

    Windows 11 has stupid power options even for desktop computer.

    I’ve put the power option on “Best performance” and there is no judder anymore.

    So yes, It was a stability problem, hardware, but software controlled.

    @Ralph : you could add this advice for desktop users (most VorpX users I guess) if it’s not already done.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!