Morrowind Help

Homepage Forums General vorpX Discussion Morrowind Help

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #17864

    So I picked up Morrowind and installed MGSO v3.0 (is this the dx9 mod that the list refers to?), and I have some issues.

    It seems to play okay normally, but with Vorpx as soon as you enter the game the graphics go weird. The intro video is a dark red vertical smear and when you get into game it’s a weird tripy texture-less greyscale. Head tracking is “working” but the image is messed up beyond belief.

    Any suggestions? Is MGSO v3.0 what I want? I read somewhere that it works someone said it worked. There are a million options during install thought, and I may have chosen poorly somewhere.



    I used the Morrowind Overhaul 2.0 IIRC. The DX9 patch that was used was MGE XE, I think you can select several MGE versions in the Overhaul install.

    Installing MGE XE alone (available at Morrowind Nexus for example) should be enough to get DX9 support. You won’t get all the other mods of the Overhaul, but to check whether things work in general it might be best to use MGE XE without any other mods first anyway.


    You got it in one.

    It’s working with a fresh install and ONLY MGE 3.8.2, not the MGO package. And 3.8.1+, I think, has an FOV option – 120 works perfectly.

    It’s beautiful, silky smooth 75 fps ALL the time. Love it. Highly recommended.

    The menus are a little fiddly, but once you get used to using edge-peak, it’s fine. Dialog text is a little squintly for me, but readable.

    Amazing VR experience.

    Trancer Spacey

    Only with MGE it workes fine. Today I installed Morrowind Overhaul 3 and things went totally weird unfortunatly. Without vorpX it’s running good and looking very nice, but with vorpX the graphics are totally messed up.

    @Ralf: So you tested it with Overhaul 2 and it works? Unfortunately the only Overhaul-version I found in the web was v3.


    You can go on and pick a choose some of the mods without difficulty.

    I currently have:

    Which makes a huge difference in the whole game in one shot.

    And I highly recommend, for OR readability:

    I also have , and installed without issue. The first two are a little redundant with the texture pack and are only marginally better than what it includes. The last in just personal preference.

    I tried several mesh enhancement mods (better bodies, etc), but ran into repeated errors on launch, that I don’t think are vorpx related (something about snowflake meshes missing?). I think that it’s the distant lands stuff in MGE/Overhaul that might be messing up vorpx, but I’m not sure.


    Ack! It seems to have filtered out my carefully formatted links!

    I currently have:

    Morrowind Texture Pack

    Which makes a huge difference in the whole game in one shot.

    And I highly recommend, for OR readability:

    MORRA BUF – MORe ReadAble Bigger UI Fonts

    I also have installed without issue:
    Apel’s Fire Retexture, Skies v3, Run Faster.

    Trancer Spacey

    Thank you, it’s looking quite nice with the texture pack. Fortunately also the Morrowind Code Patch, which helps to reduce game bugs, is working and makes no trouble. So it seems normal retexturing causes no trouble, but mods who are changing the environment.

    I did’nt try to reinstall Morrowind Overhaul again. I made a backup of my working Morrowind-folder. So I just tried Vurt’s Groundcover then, to enhance the environment with grass. But unfortunately just this mod alone seems to break the graphics when vorpX is running.

    Trancer Spacey

    By the way, what graphic card do you have? Do you use g3d-mode or z-mode? I’m asking because you wrote you always have smooth 75fps. I’m running the game on a GTX660, no problem in interiors, but outside it’s a bit to slow for smooth g3d. (Using only 5 cells distand land, 2x AA, no fancy shader settings, just sunrays and hdr.)


    I’m using geometry mode with a GTX 770 SC.

    I haven’t actually played much since I got it working – I’m still standing int the corner club…

    After reading your post, I experimented a bit and I do see the frame rate drop below 60 outside, sometimes. My suspicion is that it has to do with fire/torches/smoke in the scene but I’m not sure, the frame rate is all over the place. 60-120 fps. I probably still have some experimenting to do.

    I haven’t managed to get distant lands working, but if you do then I’ll be giving it a better go.

    I currently have it set to 8X AA, 16x anisotropic scaling, linear mipmap, Depth pixel fog. In game “real-time shaodws”, don’t seem to matter much.

    I’m still in the window for eVGA’s step-up program… there may have to be an upgrade to a 980 in my future…


    I can’t get distant lands to work with vorpx.

    Interiors are 100% white out, and exteriors and an textured grey mess.

    What setting did you use to generate your distant lands files?

    Oh, and I seen to get higher FPS at 8x AA/ 16x anisotropic than I do at 2x/2x…

    Trancer Spacey

    It seems you have a mod included which is causing this errors. Like I wrote: I had a fresh install of Morrowind, claculated distant land and everything worked finde- Then I used Vurts Groundcover, calculated the distand lands again and everything which worked fine before was messed up now, same way like you described it. Pretty uncool, because grass is such a nice thing to have in Morrowind. :-/

    But again: with a fresh install there seems to be no problems. Copy MGE into the folder and open it. Create distant land just by clicking thru the steps the programm leads you. It should work.

    I used quite low settings: not to high resolution for world textures, medium meshes and so on, because my PC is not powerful enough to get smooth fps. Perhaps when you set the settings a bit lower it works better? Or lower the visible cell-distance. I set mine to five.

    Unfortunately it’s a lot of experimentation at the moment.


    Hmmm, nope.

    Tried again to be sure. Fresh Morrowind install and just MGE. Works jsut fine until I turn on distant lands then I get a white screen outdoors (and indoors too if I enable use DL indoors). If I turn DL off in MGE it’s all good again.

    It works just fine either way without vorpx, but with vorpx DL breaks something.



    I got Morrowind with Overhaul 3.0 and DK2 working (no distant lands though). This is what I did:

    1. Clean Install of Morrowind+Tribunal+Bloodmoon (GOTY)
    2. Install MGSO3 with default values for all settings
    (at this point check that it works without vorpX and Rift)
    3. Manually download mge3.8.2-rev.0178.7z and copy contents to Morrowind folder:
    4. Start MGEgui.exe and set resolution to 1920×1080 in fullscreen (as I have no such monitor, I had to use the workaround to temporarily tick “windowed”, set the resolution, then back to fullscreen). Also deactivate “Distant Lands” (last tab).
    5. Set Rift to extended mode + primary monitor, set VorpX Config Tool “Display/Monitors” to “Use system settings”
    6. In game, open the vorpX settings by pressing DEL and play around until it’s satisfactory. For me, important settings were:
    – reduce Zoom factor to ~0.6
    – reduce Head tracking sensitivity to ~0.5
    – activate chromatic abberation and black smear fixes
    – activate gamepad (I use Xbox360 wireless)

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!