Mouse acceleration

Homepage Forums Technical Support Mouse acceleration

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #101136

    I notice that VorpX is changing my Windows mouse acceleration settings.
    After almost every game I played I have to disable my Windows mouse acceleration again.

    I have the feeling every time a profile is used with “Disable acceleration” on “False” it just enables it.

    Is there any (head tracking related?) reason not to disable acceleration?

    Can I overrule that setting so it’s always disabled?


    It’s supposed to restore the state it found when you started vorpX after a game exits and at the latest when you close vorpX to be extra sure it’s reset. Could you check whether that works correctly?


    Sometimes it does. But most of the times it keeps it enabled. (after exiting a game)
    I have not checked this behavior when closing VorpX itself. Will do.

    But if I understand correctly:
    I have acceleration disabled in Windows. I load a game with VorpX enabled where the profile setting for “disable acceleration” is false.
    The acceleration is enabled?

    If that is the case I hope you can re-view this logic.

    A global override would be very welcome.
    Then you could (for example) change the profile option “Disable acceleration” to “Mouse acceleration” with 3 options: Global, Enable, Disable.


    What should happen is the following:

    1. When you start vorpX, the current state is read and stored.
    2. Then you can choose whatever you want per game (disabled is usually preferable if a game doen’t do that itself).
    3. When you close a game and finally again when you close vorpX as a safety measure the original state is restored.

    So if everything works correctly, you should always have the same state after using vorpX that you had before. I’ll check whether there is a glitch somewhere.


    Every application I -close- while VorpX is running the acceleration is enabled for a couple of seconds and then turned off again. So not even games only, everything.
    Sometimes when switching/closing multiple applications it looks like VorpX is loosing track of it and keeps the setting enabled.
    Guess that’s the reason I could not always replicate it.

    Can you -please- give an option in VorpX to leave my mouse settings alone, this is getting very annoying.


    It does leave it alone unless you disable it for a game.

    As said above, I will check whether there is some glitch. What you describe is neither supposed to happen nor does it happen normally. It will be investigated further though.




    Same issue. Very annoying.
    Also in every game in the [DEL] menĂ¼ the acceleration is default enabled too…

    Why you love acceleration that much? Please give an option in vorpx to entirely disable that fummeling in my mouse settings. This is really, really annoying.


    The mouse acceleration setting is only relevant for older games where it can affect mouse based head tracking. vorpX does not touch your mouse acceleration setting unless you tell it to do so normally.

    Unfortunately mouse acceleration can only be turned off/on as a system wide setting, hence vorpX doesn’t touch it per default to reduce the risk of issues that naturally come with changing a system wide setting.

    What vorpX does if you change the setting for a game in the vorpX menu is remembering the state when vorpX is launched and then reset it to that state after you exit the game. So unless something goes severely wrong (e.g. the whole PC crashes while playing a game) the acceleration is always reset to the state you had before launching the game.

    Luckily the vast majoritiy of newer games aren’t affected by the Windows acceleration setting anymore, so you will only have to touch the according vorpX setting for older games where mouse acceleration actually affects head tracking.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!